summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-06-15 01:16:12 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-06-15 01:30:24 +0200
commitd220cd88d0f72f0436b3f240aec20add06ba245c (patch)
tree0a25d22223a695c617607f4e7b16f36ea2b5f9ae /dev-php/xdebug
parentdev-php/xdebug-client: bump to v2.9.6 (diff)
downloadgentoo-d220cd88d0f72f0436b3f240aec20add06ba245c.tar.gz
gentoo-d220cd88d0f72f0436b3f240aec20add06ba245c.tar.bz2
gentoo-d220cd88d0f72f0436b3f240aec20add06ba245c.zip
dev-php/xdebug: bump to v2.9.6
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/xdebug')
-rw-r--r--dev-php/xdebug/Manifest1
-rw-r--r--dev-php/xdebug/xdebug-2.9.6.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-php/xdebug/Manifest b/dev-php/xdebug/Manifest
index cb5578b4712a..3c5d6ff6eee5 100644
--- a/dev-php/xdebug/Manifest
+++ b/dev-php/xdebug/Manifest
@@ -1,2 +1,3 @@
DIST xdebug-2.9.4.tar.gz 434622 BLAKE2B bd0d0c6a46867ffba88693f142346d11b5abfab3254c549b74ff9169536c42903b1fb1cb94c3344060590b63e287878ea05c6ef7ad8343234bada3857e0dbe75 SHA512 cf19fb9fd12c32e04c18f296694d0667dfe6e14617da932804d17526c88ab19dd2307ad43d036a8c0cb1f871a964523473879da8815f346faf83ec3b9e3952e3
DIST xdebug-2.9.5.tar.gz 434947 BLAKE2B 08fd7cc92880c9b00180d495341fc7e54998cf3c2294b824d94c3c4ed982ae5b087084b776bcc4f8f4e1aa420396c803d330bc76748cf972cccab4e3f1416d38 SHA512 2a937d08468d3a2963559a56bdf9c9aa6ede3f0ee63797aa14831bcab33a5ede65b87791171a0c794eefdfcffa65bb4d0c06b5377fe03ade65f4defa6e328c72
+DIST xdebug-2.9.6.tar.gz 436208 BLAKE2B 00cfb42c41bfb44f285b97779d6ba625641fc34494465e9e791ab5458c6a608e432df0ad45c561df2f8c9aba04ab34b3a98bb5e6bfb92ace39a3ad4145f3514a SHA512 13ed07a1489ba7bc0b4e85bf56306c733e7894cea8cb442649635196606b12d92e5618ab2485e7cde4aaee2ac6752993aecd933c24fd64b5113ef619339403d2
diff --git a/dev-php/xdebug/xdebug-2.9.6.ebuild b/dev-php/xdebug/xdebug-2.9.6.ebuild
new file mode 100644
index 000000000000..95745e2c779d
--- /dev/null
+++ b/dev-php/xdebug/xdebug-2.9.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PHP_EXT_NAME="xdebug"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="yes"
+PHP_EXT_INIFILE="2.6.0-xdebug.ini"
+
+USE_PHP="php7-2 php7-3 php7-4"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+inherit php-ext-source-r3
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="A PHP debugging and profiling extension"
+HOMEPAGE="https://xdebug.org/"
+# Using tarball from GitHub for tests
+#SRC_URI="https://pecl.php.net/get/${PN}-${MY_PV}.tgz"
+SRC_URI="https://github.com/xdebug/xdebug/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ ~dev-php/xdebug-client-${PV}"
+DOCS=( README.rst CREDITS )
+PHP_EXT_ECONF_ARGS=()
+
+pkg_postinst() {
+ ewarn "We have set xdebug.default_enable to 0 (off), as xdebug can be"
+ ewarn "installed as a dependency, and not all users will want xdebug to be"
+ ewarn "enabled by default. If you want to enable it, you should edit the"
+ ewarn "ini file and set xdebug.default_enable to 1. Alternatively you can"
+ ewarn "call xdebug_enable() in your code."
+}