summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-11-30 00:33:10 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-11-30 01:39:13 +0100
commitaebde57f59d3874349f35b8aaf837a4275cfed72 (patch)
tree6e79b3ec72893a99f0196e13e7b1758445e50dcb /dev-php/zetacomponents-Base
parentdev-php/theseer-DirectoryScanner: new package (diff)
downloadgentoo-aebde57f59d3874349f35b8aaf837a4275cfed72.tar.gz
gentoo-aebde57f59d3874349f35b8aaf837a4275cfed72.tar.bz2
gentoo-aebde57f59d3874349f35b8aaf837a4275cfed72.zip
dev-php/zetacomponents-Base: new package
Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/zetacomponents-Base')
-rw-r--r--dev-php/zetacomponents-Base/Manifest1
-rw-r--r--dev-php/zetacomponents-Base/files/autoload.php53
-rw-r--r--dev-php/zetacomponents-Base/metadata.xml11
-rw-r--r--dev-php/zetacomponents-Base/zetacomponents-Base-1.9.1.ebuild26
4 files changed, 91 insertions, 0 deletions
diff --git a/dev-php/zetacomponents-Base/Manifest b/dev-php/zetacomponents-Base/Manifest
new file mode 100644
index 000000000000..d2b1d99d3293
--- /dev/null
+++ b/dev-php/zetacomponents-Base/Manifest
@@ -0,0 +1 @@
+DIST zetacomponents-Base-1.9.1.tar.gz 252350 BLAKE2B cc0d82a107fc1190b57b03ce3a594d9ffa5b3a2627cf30d7d31a1018005a8400917cf7bbd1dfeb23f46d118ae56083e147d148b3bbdba5dfea8fde0a8bcf0c46 SHA512 dd56f123c8ed3b8c0116b878120ba7763e402b8364ba404305a9ab483b1c5a341df994517f160c8a959005ab9b75a5a7af74d08b367daa3fd8f852ba4ede5e05
diff --git a/dev-php/zetacomponents-Base/files/autoload.php b/dev-php/zetacomponents-Base/files/autoload.php
new file mode 100644
index 000000000000..17bec81a6d2e
--- /dev/null
+++ b/dev-php/zetacomponents-Base/files/autoload.php
@@ -0,0 +1,53 @@
+<?php
+// @codingStandardsIgnoreFile
+// @codeCoverageIgnoreStart
+// this is an autogenerated file - do not edit
+spl_autoload_register(
+ function($class) {
+ static $classes = null;
+ if ($classes === null) {
+ $classes = array(
+ 'ezcbase' => '/base.php',
+ 'ezcbaseautoloadexception' => '/exceptions/autoload.php',
+ 'ezcbaseautoloadoptions' => '/options/autoload.php',
+ 'ezcbaseconfigurationinitializer' => '/interfaces/configuration_initializer.php',
+ 'ezcbasedoubleclassrepositoryprefixexception' => '/exceptions/double_class_repository_prefix.php',
+ 'ezcbaseexception' => '/exceptions/exception.php',
+ 'ezcbaseexportable' => '/interfaces/exportable.php',
+ 'ezcbaseextensionnotfoundexception' => '/exceptions/extension_not_found.php',
+ 'ezcbasefeatures' => '/features.php',
+ 'ezcbasefile' => '/file.php',
+ 'ezcbasefileexception' => '/exceptions/file_exception.php',
+ 'ezcbasefilefindcontext' => '/structs/file_find_context.php',
+ 'ezcbasefileioexception' => '/exceptions/file_io.php',
+ 'ezcbasefilenotfoundexception' => '/exceptions/file_not_found.php',
+ 'ezcbasefilepermissionexception' => '/exceptions/file_permission.php',
+ 'ezcbasefunctionalitynotsupportedexception' => '/exceptions/functionality_not_supported.php',
+ 'ezcbaseinit' => '/init.php',
+ 'ezcbaseinitcallbackconfiguredexception' => '/exceptions/init_callback_configured.php',
+ 'ezcbaseinitinvalidcallbackclassexception' => '/exceptions/invalid_callback_class.php',
+ 'ezcbaseinvalidparentclassexception' => '/exceptions/invalid_parent_class.php',
+ 'ezcbasemetadata' => '/metadata.php',
+ 'ezcbasemetadatapearreader' => '/metadata/pear.php',
+ 'ezcbasemetadatatarballreader' => '/metadata/tarball.php',
+ 'ezcbaseoptions' => '/options.php',
+ 'ezcbasepersistable' => '/interfaces/persistable.php',
+ 'ezcbasepropertynotfoundexception' => '/exceptions/property_not_found.php',
+ 'ezcbasepropertypermissionexception' => '/exceptions/property_permission.php',
+ 'ezcbaserepositorydirectory' => '/structs/repository_directory.php',
+ 'ezcbasesettingnotfoundexception' => '/exceptions/setting_not_found.php',
+ 'ezcbasesettingvalueexception' => '/exceptions/setting_value.php',
+ 'ezcbasestruct' => '/struct.php',
+ 'ezcbasevalueexception' => '/exceptions/value.php',
+ 'ezcbasewhateverexception' => '/exceptions/whatever.php'
+ );
+ }
+ $cn = strtolower($class);
+ if (isset($classes[$cn])) {
+ require __DIR__ . $classes[$cn];
+ }
+ },
+ true,
+ false
+);
+// @codeCoverageIgnoreEnd
diff --git a/dev-php/zetacomponents-Base/metadata.xml b/dev-php/zetacomponents-Base/metadata.xml
new file mode 100644
index 000000000000..8dbb073e53ff
--- /dev/null
+++ b/dev-php/zetacomponents-Base/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">zetacomponents/Base</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/zetacomponents-Base/zetacomponents-Base-1.9.1.ebuild b/dev-php/zetacomponents-Base/zetacomponents-Base-1.9.1.ebuild
new file mode 100644
index 000000000000..a1c68a7472bd
--- /dev/null
+++ b/dev-php/zetacomponents-Base/zetacomponents-Base-1.9.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="Base"
+
+DESCRIPTION="Base package for any Zeta component"
+HOMEPAGE="https://github.com/zetacomponents/Base"
+SRC_URI="https://github.com/zetacomponents/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="dev-lang/php:*"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_install() {
+ insinto /usr/share/php/ezc/${MY_PN}
+ doins -r src/*
+ doins "${FILESDIR}"/autoload.php
+
+ einstalldocs
+}