summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2021-11-23 10:37:25 -0500
committerBrian Evans <grknight@gentoo.org>2021-11-23 11:15:36 -0500
commit326deef67c07a9e07ca52029525c20134daf375f (patch)
tree90c6bd1a9477b3805ceacc28cdda24c6724732a2 /dev-php
parentdev-php/pecl-ps: Add PHP 8.1 target (diff)
downloadgentoo-326deef67c07a9e07ca52029525c20134daf375f.tar.gz
gentoo-326deef67c07a9e07ca52029525c20134daf375f.tar.bz2
gentoo-326deef67c07a9e07ca52029525c20134daf375f.zip
dev-php/igbinary: Revbump to add 8.1 support
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/igbinary/igbinary-3.2.6-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-php/igbinary/igbinary-3.2.6-r1.ebuild b/dev-php/igbinary/igbinary-3.2.6-r1.ebuild
new file mode 100644
index 000000000000..eecc1a37e244
--- /dev/null
+++ b/dev-php/igbinary/igbinary-3.2.6-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PHP_EXT_NAME="${PN}"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS=( CREDITS NEWS README.md )
+PHP_EXT_ECONF_ARGS=( --enable-${PN} )
+
+USE_PHP="php7-3 php7-4 php8-0 php8-1"
+
+inherit php-ext-source-r3
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+DESCRIPTION="A fast drop-in replacement for the standard PHP serialize"
+HOMEPAGE="https://github.com/igbinary/igbinary"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"