summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2021-01-24 08:55:52 -0500
committerBrian Evans <grknight@gentoo.org>2021-01-24 08:55:52 -0500
commit4049032e5a5edb995c0caa958fac923bebfe36e6 (patch)
tree357260d66aa69aec8b1db3efa06c899b360cfcb2 /dev-php
parentgui-apps/waybar: sync live (diff)
downloadgentoo-4049032e5a5edb995c0caa958fac923bebfe36e6.tar.gz
gentoo-4049032e5a5edb995c0caa958fac923bebfe36e6.tar.bz2
gentoo-4049032e5a5edb995c0caa958fac923bebfe36e6.zip
dev-php/pecl-event: Drop old
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-event/Manifest1
-rw-r--r--dev-php/pecl-event/files/pecl-event-2.5.3-no-sockets.patch12
-rw-r--r--dev-php/pecl-event/pecl-event-2.5.3-r1.ebuild60
-rw-r--r--dev-php/pecl-event/pecl-event-2.5.3.ebuild56
4 files changed, 0 insertions, 129 deletions
diff --git a/dev-php/pecl-event/Manifest b/dev-php/pecl-event/Manifest
index b61f90008523..068fee3890e2 100644
--- a/dev-php/pecl-event/Manifest
+++ b/dev-php/pecl-event/Manifest
@@ -1,2 +1 @@
-DIST event-2.5.3.tgz 140913 BLAKE2B e9b1886b65d1c307bf4a40ebe20e19f33d9e422ce98fb704c7174e953c2488b87f941fc5615bfee07e7d51e1775a0256349e023e6d8921fdd237e527ab108151 SHA512 359eee2f501444f444904ee1960d85af0b77259e59a06d9c6ae1ec008f7bda9bda5bf999d437d84416150a965466519c04e4c2f36dbca44367075fcbb46cd917
DIST event-2.5.7.tgz 141451 BLAKE2B 6d5e87b0b4892b59e2dc37dde0ae8ecafd104fbaa90fcc4d2b7183d4e3ba2f8fa182ddee90d5ebaebeb826f3e02d760ae25ce5ca01582fec9dfa5cb05dc6f5c6 SHA512 8160c3df1f6faa4b3ee37b9212a7953e5c0cdc747228517d238ea638b2b441e4b64e9d8c91d3af6bd33f33486137e9da1c7cb45b8d8400b8ab46d1ae4c03590a
diff --git a/dev-php/pecl-event/files/pecl-event-2.5.3-no-sockets.patch b/dev-php/pecl-event/files/pecl-event-2.5.3-no-sockets.patch
deleted file mode 100644
index 9b95708a6e7b..000000000000
--- a/dev-php/pecl-event/files/pecl-event-2.5.3-no-sockets.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/php7/src/fe-orig.c 2020-02-23 15:50:42.159505602 +0300
-+++ b/php7/src/fe.c 2020-02-23 15:51:09.985462245 +0300
-@@ -640,7 +640,9 @@
- PHP_ME(EventUtil, getSocketName, arginfo_event_util_get_socket_name, ZEND_ACC_PUBLIC | ZEND_ACC_STATIC)
- PHP_ME(EventUtil, getSocketFd, arginfo_event_util_get_socket_fd, ZEND_ACC_PUBLIC | ZEND_ACC_STATIC)
- PHP_ME(EventUtil, setSocketOption, arginfo_event_util_set_socket_option, ZEND_ACC_PUBLIC | ZEND_ACC_STATIC)
-+#ifdef PHP_EVENT_SOCKETS_SUPPORT
- PHP_ME(EventUtil, createSocket, arginfo_event_util_create_socket, ZEND_ACC_PUBLIC | ZEND_ACC_STATIC)
-+#endif
-
- PHP_FE_END
- };
diff --git a/dev-php/pecl-event/pecl-event-2.5.3-r1.ebuild b/dev-php/pecl-event/pecl-event-2.5.3-r1.ebuild
deleted file mode 100644
index b30711ec149f..000000000000
--- a/dev-php/pecl-event/pecl-event-2.5.3-r1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PHP_EXT_NAME="event"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-DOCS=( README.md )
-
-USE_PHP="php7-1 php7-2 php7-3 php7-4"
-
-inherit php-ext-pecl-r3
-
-KEYWORDS="~amd64 ~ia64 ~x86"
-LICENSE="PHP-3.01"
-
-DESCRIPTION="PHP wrapper for libevent2"
-SLOT="0"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.5.3-no-sockets.patch"
-)
-
-DEPEND="
- >=dev-libs/libevent-2.0.2
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )
- php_targets_php7-1? ( dev-lang/php:7.1[sockets?] )
- php_targets_php7-2? ( dev-lang/php:7.2[sockets?] )
- php_targets_php7-3? ( dev-lang/php:7.3[sockets?] )
- php_targets_php7-4? ( dev-lang/php:7.4[sockets?] )"
-
-RDEPEND="
- ${DEPEND}
- !dev-php/pecl-libevent"
-
-IUSE="debug examples +extra libressl +sockets +ssl threads"
-
-src_configure() {
- local PHP_EXT_ECONF_ARGS=(
- --with-event-core
- $(use_enable debug event-debug)
- $(use_with extra event-extra)
- $(use_with ssl event-openssl)
- $(use_with threads event-pthreads)
- $(use_enable sockets event-sockets)
- )
- php-ext-source-r3_src_configure
-}
-
-src_test() {
- local slot
- for slot in $(php_get_slots); do
- php_init_slot_env "${slot}"
- SKIP_ONLINE_TESTS="yes" NO_INTERACTION="yes" emake test
- done
-}
diff --git a/dev-php/pecl-event/pecl-event-2.5.3.ebuild b/dev-php/pecl-event/pecl-event-2.5.3.ebuild
deleted file mode 100644
index 1cb12cf06a50..000000000000
--- a/dev-php/pecl-event/pecl-event-2.5.3.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PHP_EXT_NAME="event"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-DOCS=( README.md )
-
-USE_PHP="php7-1 php7-2 php7-3 php7-4"
-
-inherit php-ext-pecl-r3
-
-KEYWORDS="amd64 ~ia64 x86"
-LICENSE="PHP-3.01"
-
-DESCRIPTION="PHP wrapper for libevent2"
-SLOT="0"
-
-DEPEND="
- >=dev-libs/libevent-2.0.2
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )
- php_targets_php7-1? ( dev-lang/php:7.1[sockets?] )
- php_targets_php7-2? ( dev-lang/php:7.2[sockets?] )
- php_targets_php7-3? ( dev-lang/php:7.3[sockets?] )
- php_targets_php7-4? ( dev-lang/php:7.4[sockets?] )"
-
-RDEPEND="
- ${DEPEND}
- !dev-php/pecl-libevent"
-
-IUSE="debug examples +extra libressl +sockets +ssl threads"
-
-src_configure() {
- local PHP_EXT_ECONF_ARGS=(
- --with-event-core
- $(use_enable debug event-debug)
- $(use_with extra event-extra)
- $(use_with ssl event-openssl)
- $(use_with threads event-pthreads)
- $(use_enable sockets event-sockets)
- )
- php-ext-source-r3_src_configure
-}
-
-src_test() {
- local slot
- for slot in $(php_get_slots); do
- php_init_slot_env "${slot}"
- SKIP_ONLINE_TESTS="yes" NO_INTERACTION="yes" emake test
- done
-}