summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2021-05-19 11:07:58 -0400
committerBrian Evans <grknight@gentoo.org>2021-05-19 11:08:55 -0400
commit47b1312114c913e9264b2887feb5763b3768e096 (patch)
tree7532fcfda08f22fafcce3468caad11bb581f1f99 /dev-php
parentnet-analyzer/netdata: 1.31.0 version bump (diff)
downloadgentoo-47b1312114c913e9264b2887feb5763b3768e096.tar.gz
gentoo-47b1312114c913e9264b2887feb5763b3768e096.tar.bz2
gentoo-47b1312114c913e9264b2887feb5763b3768e096.zip
dev-php/pecl-http: Restore helper target USE on 4.1.0
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-http/pecl-http-4.1.0.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/dev-php/pecl-http/pecl-http-4.1.0.ebuild b/dev-php/pecl-http/pecl-http-4.1.0.ebuild
index 33b34cd83beb..9ffc9765e462 100644
--- a/dev-php/pecl-http/pecl-http-4.1.0.ebuild
+++ b/dev-php/pecl-http/pecl-http-4.1.0.ebuild
@@ -9,10 +9,12 @@ PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
PHP_INI_NAME="50-http"
-USE_PHP="php8-0"
+USE_PHP="php7-3 php7-4 php8-0"
inherit php-ext-pecl-r3
+USE_PHP="php8-0"
+
KEYWORDS="~amd64 ~x86"
DESCRIPTION="Extended HTTP Support for PHP"
@@ -28,9 +30,11 @@ COMMON_DEPEND="app-arch/brotli:=
ssl? ( net-misc/curl[ssl,curl_ssl_gnutls(-)=,curl_ssl_nss(-)=,curl_ssl_openssl(-)=] )
!ssl? ( net-misc/curl[-ssl] )
"
-DEPEND="${COMMON_DEPEND}
- php_targets_php8-0? ( dev-lang/php:8.0[session(-),iconv(-)] )"
-RDEPEND="${DEPEND}"
+DEPEND="
+ php_targets_php8-0? ( ${COMMON_DEPEND} dev-lang/php:8.0[session(-),iconv(-)] )"
+RDEPEND="${DEPEND}
+ php_targets_php7-3? ( dev-php/pecl-http:7[php_targets_php7-3(-)] )
+ php_targets_php7-4? ( dev-php/pecl-http:7[php_targets_php7-4(-)] )"
PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps --without-http-libidn-dir )