summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2022-01-07 13:19:34 -0500
committerBrian Evans <grknight@gentoo.org>2022-01-07 13:20:17 -0500
commit57b49051d1cc8fce00d02480d591c806f707cd48 (patch)
tree3eb5c6e78885278ede0080a057affdc7826303e7 /dev-php
parentdev-python/pudb: add 2022.1 (diff)
downloadgentoo-57b49051d1cc8fce00d02480d591c806f707cd48.tar.gz
gentoo-57b49051d1cc8fce00d02480d591c806f707cd48.tar.bz2
gentoo-57b49051d1cc8fce00d02480d591c806f707cd48.zip
dev-php/PEAR-XML_RSS: Revbump for EAPI and adding tests
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0-r1.ebuild29
-rw-r--r--dev-php/PEAR-XML_RSS/metadata.xml1
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0-r1.ebuild b/dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..0946a4139818
--- /dev/null
+++ b/dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit php-pear-r2
+
+DESCRIPTION="PHP parser for RDF and RSS documents"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-php/PEAR-XML_Parser"
+BDEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's/_Framework_/\\Framework\\/' \
+ -e 's/_TextUI_/\\TextUI\\/' \
+ tests/*.php
+}
+
+src_test() {
+ phpunit --bootstrap "${S}/XML/RSS.php" \
+ --cache-result-file="${T}/test-results.cache" tests || die
+}
diff --git a/dev-php/PEAR-XML_RSS/metadata.xml b/dev-php/PEAR-XML_RSS/metadata.xml
index e20abea1376d..728e8459a9fe 100644
--- a/dev-php/PEAR-XML_RSS/metadata.xml
+++ b/dev-php/PEAR-XML_RSS/metadata.xml
@@ -9,4 +9,5 @@
<remote-id type="github">pear/XML_RSS</remote-id>
<remote-id type="pear">XML_RSS</remote-id>
</upstream>
+ <stabilize-allarches/>
</pkgmetadata>