summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-07-06 09:43:18 -0400
committerBrian Evans <grknight@gentoo.org>2017-07-06 10:36:27 -0400
commit630f649bb09020611a5035035347d7fee4031368 (patch)
tree3b81117e8045d3fe04942726f08e05411e2a4675 /dev-php
parentdev-php/PEAR-HTML_QuickForm_advmultiselect: Revbump for EAPI and eclass changes (diff)
downloadgentoo-630f649bb09020611a5035035347d7fee4031368.tar.gz
gentoo-630f649bb09020611a5035035347d7fee4031368.tar.bz2
gentoo-630f649bb09020611a5035035347d7fee4031368.zip
dev-php/PEAR-Console_Getargs: Revbump for EAPI and eclass changes and upstream patch
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-Console_Getargs/PEAR-Console_Getargs-1.3.5-r1.ebuild18
-rw-r--r--dev-php/PEAR-Console_Getargs/files/new-reference-fix.patch22
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-php/PEAR-Console_Getargs/PEAR-Console_Getargs-1.3.5-r1.ebuild b/dev-php/PEAR-Console_Getargs/PEAR-Console_Getargs-1.3.5-r1.ebuild
new file mode 100644
index 000000000000..991a8089f5af
--- /dev/null
+++ b/dev-php/PEAR-Console_Getargs/PEAR-Console_Getargs-1.3.5-r1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit php-pear-r2
+
+DESCRIPTION="A command-line arguments parser"
+
+LICENSE="PHP-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+src_prepare() {
+ eapply "${FILESDIR}/new-reference-fix.patch"
+ eapply_user
+}
diff --git a/dev-php/PEAR-Console_Getargs/files/new-reference-fix.patch b/dev-php/PEAR-Console_Getargs/files/new-reference-fix.patch
new file mode 100644
index 000000000000..a69aa2b9bde5
--- /dev/null
+++ b/dev-php/PEAR-Console_Getargs/files/new-reference-fix.patch
@@ -0,0 +1,22 @@
+From c769f79831c43f1cad0b4f8831276da93d28f479 Mon Sep 17 00:00:00 2001
+From: Daniel O'Connor <daniel.oconnor@gmail.com>
+Date: Sun, 6 Nov 2011 13:25:04 +1030
+Subject: [PATCH] &new vs new
+
+---
+ Console/Getargs.php | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Console/Getargs.php b/Console/Getargs.php
+index 8ba21c6..c6826ea 100644
+--- a/Console/Getargs.php
++++ b/Console/Getargs.php
+@@ -224,7 +224,7 @@ class Console_Getargs
+ function &factory($config = array(), $arguments = null)
+ {
+ // Create the options object.
+- $obj = & new Console_Getargs_Options();
++ $obj = new Console_Getargs_Options();
+
+ // Try to set up the arguments.
+ $err = $obj->init($config, $arguments);