summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-05-18 18:37:00 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-05-18 20:37:49 +0200
commit6f3b5fae4803d71534ec4832b5a12b73b3054301 (patch)
tree7015e363d97fd75f0ca2bf33c3dd47d035a355ed /dev-php
parentdev-java/velocity: removed obsolete and vulnerable 1.7-r2 (diff)
downloadgentoo-6f3b5fae4803d71534ec4832b5a12b73b3054301.tar.gz
gentoo-6f3b5fae4803d71534ec4832b5a12b73b3054301.tar.bz2
gentoo-6f3b5fae4803d71534ec4832b5a12b73b3054301.zip
dev-php/pecl-http: bump to v4.1.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-http/Manifest1
-rw-r--r--dev-php/pecl-http/files/pecl-http-4.1.0-use-getenv.patch25
-rw-r--r--dev-php/pecl-http/pecl-http-4.1.0.ebuild72
3 files changed, 98 insertions, 0 deletions
diff --git a/dev-php/pecl-http/Manifest b/dev-php/pecl-http/Manifest
index 8fc2bb40c9a8..dc929ad0735f 100644
--- a/dev-php/pecl-http/Manifest
+++ b/dev-php/pecl-http/Manifest
@@ -1,3 +1,4 @@
DIST pecl_http-3.2.1.tgz 221244 BLAKE2B b6581829fb8a800e24ccedd4d0f3efbaf558850bdc356d27a6e1d1097a8e2cfc61963a1daccd1d0f269a7cef5b243d45cdfaff5138321fe20df615dde44d19e3 SHA512 e67d4b32ba6f524e3fcf65f5497b94275e1a4a14fce97c57afe366369f368b3acdbedf364ed73cf983fb2c5f57f498adaa1100e7c936f11cbc5de1caedad7b51
DIST pecl_http-3.2.4.tgz 220631 BLAKE2B 996236cf9dd2f7d9bfaf046306e99c3ccf778261df19df8fd828b5811798f784841d89a6890e7347bd20cc6da71c966ea3ac9b17bf058e0bb766db7e1a8a6c49 SHA512 59c41d57c94a6e50e2f0b261130a24791b2845246f783b55e7f644f9a897d3650da364c5b38a860761b4a23f9266ed05000d6348bae2a7941e59d6bf5fb61a9e
DIST pecl_http-4.0.0.tgz 218259 BLAKE2B c9f5973686fd4db95a24dd4c50f217b93becc6a439066a395b0b7fec6e977154e5ae8f2261414458aed8e4a9d1281f44da2ecc67a05127610579f5be91196a88 SHA512 268b569c23f10ed72fe3c84fc5e5bf526c3e5ac345ca0556a24fbd01ce95da468d4e9aac6300d058001534ab826836793bf901e9560b744f1e20d7059be2ec79
+DIST pecl_http-4.1.0.tgz 220349 BLAKE2B 71152ee20930843636d90547339270fecf5569cb9a252a516c8150a134bf75fcb88b4fcfd129af1ca1366f4df775653b4dcdddbf0eb02426625550c1b1a0b483 SHA512 653c1dd8ec6dc738ce2dbf235a3c92522858e17ab9c0d00dd75a51bcfeb836f3fb02a6040b8b67d8d6839055286599958db844891686ca70c36031500be0bc1c
diff --git a/dev-php/pecl-http/files/pecl-http-4.1.0-use-getenv.patch b/dev-php/pecl-http/files/pecl-http-4.1.0-use-getenv.patch
new file mode 100644
index 000000000000..c3ad7d968360
--- /dev/null
+++ b/dev-php/pecl-http/files/pecl-http-4.1.0-use-getenv.patch
@@ -0,0 +1,25 @@
+commit a4f66fb42bb5203e9d1897a6cf554aa702ce0380
+Author: Thomas Deutschmann <whissi@gentoo.org>
+AuthorDate: Tue May 18 19:55:47 2021 +0200
+Commit: Thomas Deutschmann <whissi@gentoo.org>
+CommitDate: Tue May 18 19:55:47 2021 +0200
+
+ tests: use getenv() to access environment variable
+
+ Fixes
+
+ Warning: Undefined array key "PATH" in pecl-http-4.1.0/work/php8.0/tests/skipif.inc on line 56
+
+diff --git a/tests/skipif.inc b/tests/skipif.inc
+index 51272fb..76c3bd7 100644
+--- a/tests/skipif.inc
++++ b/tests/skipif.inc
+@@ -53,7 +53,7 @@ function skip_http2_test($message = "skip need http2 support") {
+ if (!(http\Client\Curl\FEATURES & http\Client\Curl\Features\HTTP2)) {
+ die("$message (FEATURES & HTTP2)\n");
+ }
+- foreach (explode(":", $_ENV["PATH"]) as $path) {
++ foreach (explode(":", getenv("PATH")) as $path) {
+ if (is_executable($path . "/nghttpd")) {
+ return;
+ }
diff --git a/dev-php/pecl-http/pecl-http-4.1.0.ebuild b/dev-php/pecl-http/pecl-http-4.1.0.ebuild
new file mode 100644
index 000000000000..7697b703d5f9
--- /dev/null
+++ b/dev-php/pecl-http/pecl-http-4.1.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PHP_EXT_NAME="http"
+PHP_EXT_PECL_PKG="pecl_http"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_INI_NAME="50-http"
+
+USE_PHP="php8-0"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Extended HTTP Support for PHP"
+LICENSE="BSD-2 MIT"
+SLOT="8"
+IUSE="ssl curl_ssl_gnutls curl_ssl_nss +curl_ssl_openssl"
+
+COMMON_DEPEND="app-arch/brotli:=
+ dev-libs/libevent
+ >=dev-php/pecl-raphf-2.0.1:7[php_targets_php8-0(-)?]
+ net-dns/libidn2
+ sys-libs/zlib
+ ssl? ( net-misc/curl[ssl,curl_ssl_gnutls(-)=,curl_ssl_nss(-)=,curl_ssl_openssl(-)=] )
+ !ssl? ( net-misc/curl[-ssl] )
+"
+DEPEND="${COMMON_DEPEND}
+ php_targets_php8-0? ( dev-lang/php:8.0[session(-),iconv(-)] )"
+RDEPEND="${DEPEND}"
+
+PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps --without-http-libidn-dir )
+
+PATCHES=( "${FILESDIR}"/${P}-use-getenv.patch )
+
+src_prepare() {
+ if use php_targets_php8-0 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}
+
+src_test() {
+ # Cannot use eclass function due to required modules
+ # All tests SKIP otherwise
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+
+ # Link in required modules for testing
+ ln -s "${EXT_DIR}/raphf.so" "modules/raphf.so" || die
+
+ sed -i \
+ 's/PHP_TEST_SHARED_EXTENSIONS)/PHP_TEST_SHARED_EXTENSIONS) -d extension=raphf/' \
+ Makefile || die
+
+ SKIP_ONLINE_TESTS=yes NO_INTERACTION="yes" emake test
+
+ # Clean up testing links
+ rm modules/raphf.so || die
+ done
+}
+
+src_install() {
+ if use php_targets_php8-0 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}