summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2022-01-07 09:17:06 -0500
committerBrian Evans <grknight@gentoo.org>2022-01-07 09:34:00 -0500
commit753c51df9d52530b21d8fd99f3dd14e69f8c2cdf (patch)
tree7cf312620015afe2086ab7c79191153d51a4036d /dev-php
parentprofiles: Mask net-libs/jreen for removal (diff)
downloadgentoo-753c51df9d52530b21d8fd99f3dd14e69f8c2cdf.tar.gz
gentoo-753c51df9d52530b21d8fd99f3dd14e69f8c2cdf.tar.bz2
gentoo-753c51df9d52530b21d8fd99f3dd14e69f8c2cdf.zip
dev-php/PHP_Timer: Drop old
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PHP_Timer/Manifest2
-rw-r--r--dev-php/PHP_Timer/PHP_Timer-1.0.5.ebuild18
-rw-r--r--dev-php/PHP_Timer/PHP_Timer-1.0.9.ebuild31
-rw-r--r--dev-php/PHP_Timer/files/autoload.php13
-rw-r--r--dev-php/PHP_Timer/files/channel.xml16
5 files changed, 0 insertions, 80 deletions
diff --git a/dev-php/PHP_Timer/Manifest b/dev-php/PHP_Timer/Manifest
index d99a7462f4c6..e502bf2d2ae4 100644
--- a/dev-php/PHP_Timer/Manifest
+++ b/dev-php/PHP_Timer/Manifest
@@ -1,3 +1 @@
-DIST PHP_Timer-1.0.5.tgz 3597 BLAKE2B cf82c3ff61a1f96a94a5d3743270be3262bc2ea28d7d71cd1c93a07c7bec950597c4da5d6dd23e4b58b8aad7c2e3bdb7aea07d761ef096e898088ca2296b43cf SHA512 da030dec608d1f8d447da6ce40e995ca818064e3a4b2f2eca1819a77a12875843a25bba1ffd253043ef3ac62a6dc1a16c5e7ba9b792b99b54d0713090478be84
-DIST PHP_Timer-1.0.9.tar.gz 3740 BLAKE2B d551fd676046e6bb653fb9a9bde7a976b9b2081d26caee23177b899fa01e11ae1fb2183234ab43745798c058222574b1523064cc07d25485315eef9090f892a5 SHA512 96db90cf2af18fabcf44bdd4dbb5d298402ed2c8e49f3033fd1b89b3aa8c880d9f8677897d4d542a0db6348bdd9c697042deb0b6e26242adebfde1bcdb4bc559
DIST PHP_Timer-2.1.2.tar.gz 7090 BLAKE2B c99dd69433b3579e9ed81f06188cac280b6ac383bce12acd9c6a00b5a6d6017a94c427692b639ad1516c1faebec8e160b7cd5c7e5e96043dd3dcb6d283d2095b SHA512 199175e048560756867180cd99a3ca1766431d14091f1448cd8011df5f7824504a6c586ef15d9e53374bdb9dbd1731c05b44509e59d92d725908ec2c46d7d576
diff --git a/dev-php/PHP_Timer/PHP_Timer-1.0.5.ebuild b/dev-php/PHP_Timer/PHP_Timer-1.0.5.ebuild
deleted file mode 100644
index 6e31e37ca148..000000000000
--- a/dev-php/PHP_Timer/PHP_Timer-1.0.5.ebuild
+++ /dev/null
@@ -1,18 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PHP_PEAR_CHANNEL="${FILESDIR}/channel.xml"
-PHP_PEAR_DOMAIN="pear.phpunit.de"
-PHP_PEAR_PKG_NAME="PHP_Timer"
-
-inherit php-pear-r2
-
-DESCRIPTION="Utility class for timing"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~hppa x86"
-IUSE=""
-HOMEPAGE="http://pear.phpunit.de/"
-SRC_URI="http://${PHP_PEAR_URI}/get/${PEAR_P}.tgz"
diff --git a/dev-php/PHP_Timer/PHP_Timer-1.0.9.ebuild b/dev-php/PHP_Timer/PHP_Timer-1.0.9.ebuild
deleted file mode 100644
index 584ae19d7a7f..000000000000
--- a/dev-php/PHP_Timer/PHP_Timer-1.0.9.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_PN="php-timer"
-
-DESCRIPTION="Utility class for timing"
-HOMEPAGE="https://phpunit.de"
-SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ppc ppc64 ~s390 sparc x86"
-IUSE=""
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-RDEPEND="dev-php/fedora-autoloader
- >=dev-lang/php-5.6:*"
-
-src_install() {
- insinto /usr/share/php/PHP/Timer
- doins -r src/Timer.php
- doins "${FILESDIR}/autoload.php"
-}
-
-pkg_postinst() {
- ewarn "This library now loads via /usr/share/php/PHP/Timer/autoload.php"
- ewarn "Please update any scripts to require the autoloader"
-}
diff --git a/dev-php/PHP_Timer/files/autoload.php b/dev-php/PHP_Timer/files/autoload.php
deleted file mode 100644
index bb0974e087d6..000000000000
--- a/dev-php/PHP_Timer/files/autoload.php
+++ /dev/null
@@ -1,13 +0,0 @@
-<?php
-/* Autoloader for dev-php/PHP_Timer */
-
-if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
- require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
-}
-
-\Fedora\Autoloader\Autoload::addClassMap(
- array(
- 'php_timer' => '/Timer.php',
- ),
- __DIR__
-);
diff --git a/dev-php/PHP_Timer/files/channel.xml b/dev-php/PHP_Timer/files/channel.xml
deleted file mode 100644
index 91bb6786f543..000000000000
--- a/dev-php/PHP_Timer/files/channel.xml
+++ /dev/null
@@ -1,16 +0,0 @@
-<?xml version="1.0" encoding="UTF-8" ?>
-<channel version="1.0" xmlns="http://pear.php.net/channel-1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://pear.php.net/channel-1.0 http://pear.php.net/dtd/channel-1.0.xsd">
- <name>pear.phpunit.de</name>
- <summary>PHPUnit PEAR Channel</summary>
- <suggestedalias>phpunit</suggestedalias>
- <servers>
- <primary>
- <rest>
- <baseurl type="REST1.0">http://pear.phpunit.de/rest/</baseurl>
- <baseurl type="REST1.1">http://pear.phpunit.de/rest/</baseurl>
- <baseurl type="REST1.2">http://pear.phpunit.de/rest/</baseurl>
- <baseurl type="REST1.3">http://pear.phpunit.de/rest/</baseurl>
- </rest>
- </primary>
- </servers>
-</channel> \ No newline at end of file