summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-07-24 15:51:46 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-07-24 15:52:04 -0400
commit79ed9d680ecfbeec78c9bd38a3cc3d770124e5fa (patch)
tree21b5b51b96d03dd138aa61aa8ab6c621c306b72c /dev-php
parentsci-libs/mpir: (diff)
downloadgentoo-79ed9d680ecfbeec78c9bd38a3cc3d770124e5fa.tar.gz
gentoo-79ed9d680ecfbeec78c9bd38a3cc3d770124e5fa.tar.bz2
gentoo-79ed9d680ecfbeec78c9bd38a3cc3d770124e5fa.zip
dev-php/PHPMailer: new revision to fix CVE-2017-11503.
This quick workaround simply removes the problematic example. Gentoo-Bug: 626060 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PHPMailer/PHPMailer-5.2.23-r1.ebuild (renamed from dev-php/PHPMailer/PHPMailer-5.2.23.ebuild)7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-php/PHPMailer/PHPMailer-5.2.23.ebuild b/dev-php/PHPMailer/PHPMailer-5.2.23-r1.ebuild
index 8b5977bf1cf7..e5e14253a059 100644
--- a/dev-php/PHPMailer/PHPMailer-5.2.23.ebuild
+++ b/dev-php/PHPMailer/PHPMailer-5.2.23-r1.ebuild
@@ -16,6 +16,13 @@ RDEPEND="dev-lang/php:*"
DEPEND="${RDEPEND}
doc? ( dev-php/phpDocumentor )"
+src_prepare() {
+ default
+
+ # Bug 626060 (CVE-2017-11503) temporary workaround.
+ rm examples/code_generator.phps || die
+}
+
src_compile(){
if use doc; then
phpdoc --filename="class.*.php" \