summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-09-06 10:14:49 -0400
committerMichael Orlitzky <mjo@gentoo.org>2022-09-06 10:14:56 -0400
commit8a53636f18433712c81b056789aa92fa251a4151 (patch)
tree2076436d0f06e896ea21182173edebb8dd50063b /dev-php
parentsci-mathematics/giac: add 1.9.0.21, drop 1.9.0.19 (diff)
downloadgentoo-8a53636f18433712c81b056789aa92fa251a4151.tar.gz
gentoo-8a53636f18433712c81b056789aa92fa251a4151.tar.bz2
gentoo-8a53636f18433712c81b056789aa92fa251a4151.zip
dev-php/PHPMailer: add 6.6.4, drop 6.5.1
This new version uses EAPI=8 and drops USE=doc. It looks like building the API documentation requires a new version of dev-php/phpDocumentor, and that package has been a headache for many years. Closes: https://bugs.gentoo.org/868549 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PHPMailer/Manifest2
-rw-r--r--dev-php/PHPMailer/PHPMailer-6.6.4.ebuild (renamed from dev-php/PHPMailer/PHPMailer-6.5.1.ebuild)29
2 files changed, 4 insertions, 27 deletions
diff --git a/dev-php/PHPMailer/Manifest b/dev-php/PHPMailer/Manifest
index 082765170b57..0ca8829c661a 100644
--- a/dev-php/PHPMailer/Manifest
+++ b/dev-php/PHPMailer/Manifest
@@ -1,2 +1,2 @@
DIST PHPMailer-6.5.0.tar.gz 99073 BLAKE2B dcb917233da29ab45305f7cf0405f9bb384bd4f98f062a74d94a168868d0cd92017e555bf8e7139130dd669e0a04917e3789c548b5165112d591aa403bfd56b8 SHA512 0632ec8b80c30393b00aebbadde7dd032eb2553232a100a74d69b6ed6465adf1eb3a4acca0aaf040665a978e7507aee9350b092336056ccb5306fbaea4640376
-DIST PHPMailer-6.5.1.tar.gz 99913 BLAKE2B bf51e2caa0ff1d113d6f96f5c1ee055bacd40f8a251302452eb2ebbe06d1f926935b5d85c1b9e85d115180473b76077f753f0c8af04aa86c86db3431c8a412f2 SHA512 0f8e9e3368edfdb67c701a0f42c548379c9528a90bc016444ebdc9614967ca421fa706b5f1b2de89a91fa98f7e535fb67da578ac6ba1b73f673ba7b45a198f0e
+DIST PHPMailer-6.6.4.tar.gz 102883 BLAKE2B d05eca221b3058e6632ab47c3d93d5f5cc76333351c75af537642a7850c5fb77c825e53a77321e4a63d7b06e41afb468e4dd5fe2f9b5f045ae8ed6f8543ef2ac SHA512 94ef038b59f8cf840205993d994070228a4237a19c153a0a9486e68a0289468cd882b2450482bdafb15f163c526c723dff3903919de872c6888b49273b718e87
diff --git a/dev-php/PHPMailer/PHPMailer-6.5.1.ebuild b/dev-php/PHPMailer/PHPMailer-6.6.4.ebuild
index 48dc349297f3..ec7c08d4385e 100644
--- a/dev-php/PHPMailer/PHPMailer-6.5.1.ebuild
+++ b/dev-php/PHPMailer/PHPMailer-6.6.4.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
DESCRIPTION="Full-featured email creation and transfer class for PHP"
HOMEPAGE="https://github.com/PHPMailer/PHPMailer"
@@ -13,7 +13,7 @@ KEYWORDS="~amd64 ~x86"
# To help out the Composer children, the tests and examples are missing
# from the release tarballs.
-IUSE="doc idn ssl"
+IUSE="idn ssl"
# The ctype and filter extensions get used unconditionally, with no
# fallback and no "extension missing" exception. All of the other
@@ -33,28 +33,6 @@ RDEPEND="
idn? ( dev-lang/php:*[ctype,filter,intl,unicode] )
!idn? ( dev-lang/php:*[ctype,filter] )
)"
-BDEPEND="doc? ( dev-php/phpDocumentor )"
-
-src_prepare() {
- default
-
- # OAuth.php relies on a (now non-nonexistent) autoloader. We remove
- # it early so that we don't generate documentation for it later on.
- rm src/OAuth.php || die 'failed to remove src/OAuth.php'
-}
-
-src_compile() {
- if use doc; then
- phpdoc --filename="src/*.php" \
- --target="./html" \
- --cache-folder="${T}" \
- --title="${PN}" \
- --sourcecode \
- --force \
- --progressbar \
- || die "failed to generate API documentation"
- fi
-}
src_install() {
# The PHPMailer class loads its language files
@@ -63,7 +41,6 @@ src_install() {
doins -r language src
dodoc README.md SECURITY.md
- use doc && dodoc -r html/*
}
pkg_postinst() {