summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2021-11-23 10:28:05 -0500
committerBrian Evans <grknight@gentoo.org>2021-11-23 11:15:35 -0500
commit953d60646be3ce87060e8b18e127d432876ae226 (patch)
tree8c26a7942ecbe8c40f623f2823a64e7ff5a18828 /dev-php
parentdev-php/pecl-pam: Add 8.1 target (diff)
downloadgentoo-953d60646be3ce87060e8b18e127d432876ae226.tar.gz
gentoo-953d60646be3ce87060e8b18e127d432876ae226.tar.bz2
gentoo-953d60646be3ce87060e8b18e127d432876ae226.zip
dev-php/pecl-pam: Drop old
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-pam/Manifest1
-rw-r--r--dev-php/pecl-pam/files/1.0.3-php7.patch118
-rw-r--r--dev-php/pecl-pam/pecl-pam-1.0.3-r3.ebuild41
3 files changed, 0 insertions, 160 deletions
diff --git a/dev-php/pecl-pam/Manifest b/dev-php/pecl-pam/Manifest
index 7da8caaeff39..2c4833e6bb65 100644
--- a/dev-php/pecl-pam/Manifest
+++ b/dev-php/pecl-pam/Manifest
@@ -1,2 +1 @@
-DIST pam-1.0.3.tgz 6671 BLAKE2B f416fd0e47d3fda6a1d86e44a7ca17fc9a0428f976f18e2b663a2fd1e09b790cd069ca16d930d6dca6554762ca59bda987929e52365ed813949c1a93291c1dcc SHA512 3580582f1456b31be30a713cadaaca106527f2d4f3f12032b5d3617cc361aaf49539a9db3dd27221ce40320187abaac0f6ad4e23cdfe5eaa94436e3eaef3fb9c
DIST pam-2.2.3.tgz 9422 BLAKE2B 4d10ad40bdfbaa54225723a46a78dbe1609d89cf75d0ca73345e3346fb437a5500e451357b3b0bbcce88c13f8a54dec5b39e9c0741a6e89c0b3936cbb05da91a SHA512 1adc72b1517e224f36f960134d3444d36e6fa5a6868ce4bc1b87edbbfb09406910774061988300094ebf637ee54c5f5a43e0c42c8e2ab78c81a0910063d48c51
diff --git a/dev-php/pecl-pam/files/1.0.3-php7.patch b/dev-php/pecl-pam/files/1.0.3-php7.patch
deleted file mode 100644
index d56fffb08d38..000000000000
--- a/dev-php/pecl-pam/files/1.0.3-php7.patch
+++ /dev/null
@@ -1,118 +0,0 @@
---- a/pam.c 2016-12-01 14:29:27.453904230 -0500
-+++ b/pam.c 2016-12-01 14:27:26.496109755 -0500
-@@ -227,8 +227,13 @@
- PHP_FUNCTION(pam_auth)
- {
- char *username, *password;
-+#if PHP_MAJOR_VERSION >= 7
-+ size_t username_len, password_len;
-+ zval *status = NULL, *server, *remote_addr;
-+#else
- int username_len, password_len;
- zval *status = NULL, **server, **remote_addr;
-+#endif
- zend_bool checkacctmgmt = 1;
-
- pam_auth_t userinfo = {NULL, NULL};
-@@ -248,22 +253,37 @@
- if (status) {
- spprintf(&error_msg, 0, "%s (in %s)", (char *) pam_strerror(pamh, result), "pam_start");
- zval_dtor(status);
-+#if PHP_MAJOR_VERSION >= 7
-+ ZVAL_STRING(status, error_msg);
-+ efree(error_msg);
-+#else
- ZVAL_STRING(status, error_msg, 0);
-+#endif
- }
- RETURN_FALSE;
- }
-
-+#if PHP_MAJOR_VERSION >= 7
-+ if ((remote_addr = zend_hash_str_find(Z_ARR(PG(http_globals)[TRACK_VARS_SERVER]), "REMOTE_ADDR", sizeof("REMOTE_ADDR")-1)) != NULL && Z_TYPE_P(remote_addr) == IS_STRING) {
-+ pam_set_item(pamh, PAM_RHOST, Z_STRVAL_P(remote_addr));
-+#else
- if (zend_hash_find(&EG(symbol_table), "_SERVER", sizeof("_SERVER"), (void **)&server) == SUCCESS && Z_TYPE_PP(server) == IS_ARRAY) {
- if (zend_hash_find(Z_ARRVAL_PP(server), "REMOTE_ADDR", sizeof("REMOTE_ADDR"), (void **)&remote_addr) == SUCCESS && Z_TYPE_PP(remote_addr) == IS_STRING) {
- pam_set_item(pamh, PAM_RHOST, Z_STRVAL_PP(remote_addr));
- }
-+#endif
- }
-
- if ((result = pam_authenticate(pamh, PAM_DISALLOW_NULL_AUTHTOK)) != PAM_SUCCESS) {
- if (status) {
- spprintf(&error_msg, 0, "%s (in %s)", (char *) pam_strerror(pamh, result), "pam_authenticate");
- zval_dtor(status);
-+#if PHP_MAJOR_VERSION >= 7
-+ ZVAL_STRING(status, error_msg);
-+ efree(error_msg);
-+#else
- ZVAL_STRING(status, error_msg, 0);
-+#endif
- }
- pam_end(pamh, PAM_SUCCESS);
- RETURN_FALSE;
-@@ -274,7 +294,12 @@
- if (status) {
- spprintf(&error_msg, 0, "%s (in %s)", (char *) pam_strerror(pamh, result), "pam_acct_mgmt");
- zval_dtor(status);
-+#if PHP_MAJOR_VERSION >= 7
-+ ZVAL_STRING(status, error_msg);
-+ efree(error_msg);
-+#else
- ZVAL_STRING(status, error_msg, 0);
-+#endif
- }
- pam_end(pamh, PAM_SUCCESS);
- RETURN_FALSE;
-@@ -291,7 +316,11 @@
- PHP_FUNCTION(pam_chpass)
- {
- char *username, *oldpass, *newpass;
-+#if PHP_MAJOR_VERSION >= 7
-+ size_t username_len, oldpass_len, newpass_len;
-+#else
- int username_len, oldpass_len, newpass_len;
-+#endif
- zval *status = NULL;
-
- pam_chpass_t userinfo = {NULL, NULL, NULL, 0};
-@@ -312,7 +341,12 @@
- if (status) {
- spprintf(&error_msg, 0, "%s (in %s)", (char *) pam_strerror(pamh, result), "pam_start");
- zval_dtor(status);
-+#if PHP_MAJOR_VERSION >= 7
-+ ZVAL_STRING(status, error_msg);
-+ efree(error_msg);
-+#else
- ZVAL_STRING(status, error_msg, 0);
-+#endif
- }
- RETURN_FALSE;
- }
-@@ -321,7 +355,12 @@
- if (status) {
- spprintf(&error_msg, 0, "%s (in %s)", (char *) pam_strerror(pamh, result), "pam_authenticate");
- zval_dtor(status);
-+#if PHP_MAJOR_VERSION >= 7
-+ ZVAL_STRING(status, error_msg);
-+ efree(error_msg);
-+#else
- ZVAL_STRING(status, error_msg, 0);
-+#endif
- }
- pam_end(pamh, PAM_SUCCESS);
- RETURN_FALSE;
-@@ -331,7 +370,12 @@
- if (status) {
- spprintf(&error_msg, 0, "%s (in %s)", (char *) pam_strerror(pamh, result), "pam_chauthtok");
- zval_dtor(status);
-+#if PHP_MAJOR_VERSION >= 7
-+ ZVAL_STRING(status, error_msg);
-+ efree(error_msg);
-+#else
- ZVAL_STRING(status, error_msg, 0);
-+#endif
- }
- pam_end(pamh, PAM_SUCCESS);
- RETURN_FALSE;
diff --git a/dev-php/pecl-pam/pecl-pam-1.0.3-r3.ebuild b/dev-php/pecl-pam/pecl-pam-1.0.3-r3.ebuild
deleted file mode 100644
index 5827d6ef1d27..000000000000
--- a/dev-php/pecl-pam/pecl-pam-1.0.3-r3.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PHP_EXT_NAME="pam"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-DOCS=( README )
-
-USE_PHP="php7-2 php7-3 php7-4"
-
-inherit php-ext-pecl-r3 pam
-
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="This extension provides PAM (Pluggable Authentication Modules) integration"
-LICENSE="PHP-2.02"
-SLOT="0"
-IUSE="debug"
-
-DEPEND="sys-libs/pam"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}/${PV}-php7.patch" )
-
-src_prepare() {
- #Fix DOS line endings
- sed -i 's/\r$//' -- pam.c || die
- php-ext-source-r3_src_prepare
-}
-
-src_configure() {
- local PHP_EXT_ECONF_ARGS=( --with-pam=/usr $(use_enable debug) )
- php-ext-source-r3_src_configure
-}
-
-src_install() {
- pamd_mimic_system php auth account password
- php-ext-pecl-r3_src_install
-}