summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2015-12-02 12:11:08 -0500
committerBrian Evans <grknight@gentoo.org>2015-12-02 12:11:08 -0500
commitb452ef821a4011630b0fa64ca67a619fb175e95f (patch)
tree260b277120b8c3b8e3bda61293897be0129370d0 /dev-php
parentsys-power/powertop: merge latest release and live ebuild (diff)
downloadgentoo-b452ef821a4011630b0fa64ca67a619fb175e95f.tar.gz
gentoo-b452ef821a4011630b0fa64ca67a619fb175e95f.tar.bz2
gentoo-b452ef821a4011630b0fa64ca67a619fb175e95f.zip
dev-php/phpdepend: Version bump
Convert from PEAR to PHAR archive Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/phpdepend/Manifest1
-rw-r--r--dev-php/phpdepend/phpdepend-2.2.2.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-php/phpdepend/Manifest b/dev-php/phpdepend/Manifest
index f4042b67caf4..34dba0518075 100644
--- a/dev-php/phpdepend/Manifest
+++ b/dev-php/phpdepend/Manifest
@@ -1 +1,2 @@
DIST PHP_Depend-1.1.1.tgz 181421 SHA256 64a03e82f6b38b4bd0187a27c2cc2bf47c76790b0f4e806dcdeab36ccc6e40f9 SHA512 688e8d0000a14fcc5eb4469d02177c6894f9172d2ae3813712c0af745f75327b6434a1a770d1c299bfce7c380fe5aeb3b9f9de26f4bf984d733437142bf7621b WHIRLPOOL f492e67b6e77985face1b50814dcbe4744d08cd83b8abfac8bc36254f4b67a866a53d3e15a9020a4a2ded7d5c12bbf36b949b2590aa778c8f5bd4ee7371679b6
+DIST phpdepend-2.2.2.phar 677194 SHA256 fdf8439b1485a6e8f02817e31621b5f929aad43dac9a672d076b054ecd354e4c SHA512 47519aa9f60b2dd393794fc6588f10f247b035367d514234d1e84bb564ff4ebd148dd299342722e4629847b0c0b625ba61a30bbe374215e4731a6d8187374ccc WHIRLPOOL df88d89480577ee662a553884642fbbebe00ae6764c2754ded10e237a54bd1da1d9199874158d0c7bf2e46bd98296596fb5cda4bd96407a40f04c25439a5a4b8
diff --git a/dev-php/phpdepend/phpdepend-2.2.2.ebuild b/dev-php/phpdepend/phpdepend-2.2.2.ebuild
new file mode 100644
index 000000000000..284eb7ca982c
--- /dev/null
+++ b/dev-php/phpdepend/phpdepend-2.2.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="Static code analyser for PHP"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+HOMEPAGE="http://www.pdepend.org"
+SRC_URI="http://static.pdepend.org/php/${PV}/pdepend.phar -> ${P}.phar"
+
+RDEPEND=">=dev-lang/php-5.2.3:*[phar]"
+S="${WORKDIR}"
+
+src_unpack() { :; }
+
+src_install() {
+ insinto /usr/share/php/${PN}
+ insopts -m755
+ newins "${DISTDIR}/${P}.phar" ${PN}.phar
+ dosym /usr/share/php/${PN}/${PN}.phar /usr/bin/${PN}
+}