summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-05-27 20:30:36 -0400
committerBrian Evans <grknight@gentoo.org>2017-05-27 20:31:44 -0400
commitb5cf05b080425654e2d5cc7c560559f602475cfa (patch)
treec935faa6cd5289f9f1112d73be641c475d76c21f /dev-php
parentdev-perl/Devel-Cover: Cleanup old re bug #615730 (diff)
downloadgentoo-b5cf05b080425654e2d5cc7c560559f602475cfa.tar.gz
gentoo-b5cf05b080425654e2d5cc7c560559f602475cfa.tar.bz2
gentoo-b5cf05b080425654e2d5cc7c560559f602475cfa.zip
dev-php/File_Iterator: Fix stable 1.3.4 by changing eclass
Does not affect installed files Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/File_Iterator/File_Iterator-1.3.4.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/dev-php/File_Iterator/File_Iterator-1.3.4.ebuild b/dev-php/File_Iterator/File_Iterator-1.3.4.ebuild
index 03524e3b4947..46a825640e34 100644
--- a/dev-php/File_Iterator/File_Iterator-1.3.4.ebuild
+++ b/dev-php/File_Iterator/File_Iterator-1.3.4.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=6
-PHP_PEAR_URI="pear.phpunit.de"
+PHP_PEAR_DOMAIN="pear.phpunit.de"
PHP_PEAR_CHANNEL="${FILESDIR}/channel.xml"
-PHP_PEAR_PN="File_Iterator"
-inherit php-pear-lib-r1
+PHP_PEAR_PKG_NAME="File_Iterator"
+inherit php-pear-r2
DESCRIPTION="FilterIterator implementation that filters files based on a list of suffixes"
LICENSE="BSD"
@@ -14,3 +14,5 @@ SLOT="0"
KEYWORDS="amd64 hppa x86"
IUSE=""
HOMEPAGE="https://github.com/sebastianbergmann/php-file-iterator"
+SRC_URI="http://${PHP_PEAR_URI}/get/${PEAR_P}.tgz"
+DOCS=( ChangeLog.markdown README.markdown )