summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2019-11-02 22:09:52 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2019-11-15 22:54:49 +0100
commitd62bab85f4466f694685606e51e664896a1c8146 (patch)
tree7404d37f3e01a150ca08486c59e33945aa77a84e /dev-php
parentdev-libs/mongo-c-driver: bump to 1.15.1 (diff)
downloadgentoo-d62bab85f4466f694685606e51e664896a1c8146.tar.gz
gentoo-d62bab85f4466f694685606e51e664896a1c8146.tar.bz2
gentoo-d62bab85f4466f694685606e51e664896a1c8146.zip
dev-php/pecl-mongodb: bump to 1.6.0
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Alexys Jacob <ultrabug@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-mongodb/Manifest1
-rw-r--r--dev-php/pecl-mongodb/pecl-mongodb-1.6.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-php/pecl-mongodb/Manifest b/dev-php/pecl-mongodb/Manifest
index 4f129ed93d44..458572d32114 100644
--- a/dev-php/pecl-mongodb/Manifest
+++ b/dev-php/pecl-mongodb/Manifest
@@ -1,3 +1,4 @@
DIST mongodb-1.3.3.tgz 925476 BLAKE2B 845abd4c7cf5dbb1fb3b04c5fc4070f0a360874ac566f1988025701258141a89afaa0e60c3d7166484fa37eda4ef08d94deeabdcc2ebe2a4f221dcf83aff20df SHA512 16c82ada278eac6996065d3c594237fbb8c1a7fe4e21828aa8af9ef98033cf6dfaf0fee90095e8116e946e620b551a6122238f85865a6c47d4d087f784cd54ea
DIST mongodb-1.5.3.tgz 1059580 BLAKE2B 23bd5f6b0f218cf55bd5713a770f3990d5c1492925623712583356d8aee42a1b47519b93ba64036aaf98f97ab4b1b30de9d8aa39659f2575c4f4dba3892d574d SHA512 35704e75bd7867a436d953c00c7560c9a08a4fa8f3555d7cc00aeda34e87c6c7aa7ecc1d7f674747e34f4f8dac35d320f6317e60229528ea9782bbe669bafec0
DIST mongodb-1.5.5.tgz 1060017 BLAKE2B 475ca0f6a1cbd5270c9bde0f195d6092ef25441e0cee0a45ed378a868bd1ad27c7a77c4f4702b6f82004433805563cdaa728cbc11bb5beff83b982122cad339b SHA512 1eefc8f8e359a979082dc7808e89ff5418cd2dc73d4250638e33dc32cce40ef42502e9dbbb07303381e0062b84818568034f4e4cda8c8bf905513d00bf008392
+DIST mongodb-1.6.0.tgz 1096156 BLAKE2B 16c3b1d07d31d29a214aba320347f8e40cfc4f0dae8b0713b02cd0e3ff98fd54b09217472f333722228efdfcae755bbdbfe58da7db89d4dda2893ba7b3b0e8bb SHA512 e75dc607bf41bb71a0fce3b73785ef4203af97a3e8b21bf70a80c2216e9530463a6aaca55b013a4fa2f3c4eb72405a25209935ea1a238475f990763af54aa641
diff --git a/dev-php/pecl-mongodb/pecl-mongodb-1.6.0.ebuild b/dev-php/pecl-mongodb/pecl-mongodb-1.6.0.ebuild
new file mode 100644
index 000000000000..18b9f1a79d6d
--- /dev/null
+++ b/dev-php/pecl-mongodb/pecl-mongodb-1.6.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PHP_EXT_NAME="mongodb"
+USE_PHP="php7-1 php7-2 php7-3"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="MongoDB database driver for PHP"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl sasl test"
+
+PHP_DEPEND="
+ php_targets_php7-1? ( dev-lang/php:7.1[json,ssl,zlib] )
+ php_targets_php7-2? ( dev-lang/php:7.2[json,ssl,zlib] )
+ php_targets_php7-3? ( dev-lang/php:7.3[json,ssl,zlib] )"
+COMMON_DEPEND="${PHP_DEPEND}
+ >=dev-libs/libbson-1.15.1
+ >=dev-libs/mongo-c-driver-1.15.1[sasl?,ssl]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ sasl? ( dev-libs/cyrus-sasl )"
+DEPEND="${COMMON_DEPEND}
+ test? ( dev-db/mongodb )"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="${PHP_DEPEND}
+ virtual/pkgconfig"
+
+# No tests on x86 because tests require dev-db/mongodb which don't support
+# x86 anymore (bug #645994)
+RESTRICT="x86? ( test )
+ !test? ( test )"
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-mongodb
+ --with-libbson
+ --with-libmongoc
+ --with-mongodb-sasl=$(usex sasl)
+ )
+ php-ext-source-r3_src_configure
+}
+
+# FEATURES="test" emerge dev-php/pecl-mongodb
+src_test() {
+ local PORT=27017
+ mongod --port ${PORT} --bind_ip 127.0.0.1 --nounixsocket --fork \
+ --dbpath="${T}" --logpath="${T}/mongod.log" || die
+ php-ext-pecl-r3_src_test
+ kill $(<"${T}/mongod.lock")
+}