summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-01-25 10:06:50 -0500
committerBrian Evans <grknight@gentoo.org>2016-01-25 10:06:50 -0500
commite08d25d32ca35cf089b0e96723e9d19d7b2cc787 (patch)
tree8cfb1af4d536ae8f72675f544e9b555dd11fd3af /dev-php
parentapp-doc/doxygen: take over maintainership (diff)
downloadgentoo-e08d25d32ca35cf089b0e96723e9d19d7b2cc787.tar.gz
gentoo-e08d25d32ca35cf089b0e96723e9d19d7b2cc787.tar.bz2
gentoo-e08d25d32ca35cf089b0e96723e9d19d7b2cc787.zip
dev-php/pecl-apcu_bc: Fix bug 572864 by changing name of the ini file created
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.1-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.1-r1.ebuild b/dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..a78ab92196a3
--- /dev/null
+++ b/dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PHP_EXT_NAME="apc"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README.md"
+
+USE_PHP="php7-0"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Provides APC backwards compatibility functions via APCu"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-php/pecl-apcu[php_targets_php7-0]"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ # Refine function to rename the output ini file for this extension
+ # to load in the correct order. Bug 572864
+ php-ext-source-r2_buildinilist() {
+ # Work out the list of <ext>.ini files to edit/add to
+ if [[ -z "${PHPSAPILIST}" ]] ; then
+ PHPSAPILIST="apache2 cli cgi fpm embed phpdbg"
+ fi
+
+ PHPINIFILELIST=""
+ local x
+ for x in ${PHPSAPILIST} ; do
+ if [[ -f "${EPREFIX}/etc/php/${x}-${1}/php.ini" ]] ; then
+ PHPINIFILELIST="${PHPINIFILELIST} etc/php/${x}-${1}/ext/bc_apcu.ini"
+ fi
+ done
+ PHPFULLINIFILELIST="${PHPFULLINIFILELIST} ${PHPINIFILELIST}"
+ }
+
+ php-ext-pecl-r2_src_install
+}