summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2020-12-09 16:35:18 -0500
committerBrian Evans <grknight@gentoo.org>2020-12-09 16:35:18 -0500
commitef73397e19267d4eab5c2c9c27610463ef01bf03 (patch)
treea268afe3bb3a5ecdae7c46207e4879e4cc27a058 /dev-php
parentmedia-video/aegisub: migrate to lua-single.eclass (diff)
downloadgentoo-ef73397e19267d4eab5c2c9c27610463ef01bf03.tar.gz
gentoo-ef73397e19267d4eab5c2c9c27610463ef01bf03.tar.bz2
gentoo-ef73397e19267d4eab5c2c9c27610463ef01bf03.zip
dev-php/xdebug: Version bump for 3.0
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/xdebug/Manifest1
-rw-r--r--dev-php/xdebug/files/3.0-xdebug.ini41
-rw-r--r--dev-php/xdebug/xdebug-3.0.1.ebuild57
3 files changed, 99 insertions, 0 deletions
diff --git a/dev-php/xdebug/Manifest b/dev-php/xdebug/Manifest
index 65cb9595e140..cc14e8baedb3 100644
--- a/dev-php/xdebug/Manifest
+++ b/dev-php/xdebug/Manifest
@@ -3,3 +3,4 @@ DIST xdebug-2.9.5.tar.gz 434947 BLAKE2B 08fd7cc92880c9b00180d495341fc7e54998cf3c
DIST xdebug-2.9.6.tar.gz 436208 BLAKE2B 00cfb42c41bfb44f285b97779d6ba625641fc34494465e9e791ab5458c6a608e432df0ad45c561df2f8c9aba04ab34b3a98bb5e6bfb92ace39a3ad4145f3514a SHA512 13ed07a1489ba7bc0b4e85bf56306c733e7894cea8cb442649635196606b12d92e5618ab2485e7cde4aaee2ac6752993aecd933c24fd64b5113ef619339403d2
DIST xdebug-2.9.7.tar.gz 437517 BLAKE2B 6d3cb615b6b75354e5dc993a2de9f90b5865ee1a98935c084a9d7a4e1d03cceb71278b06da1d5e47f2b4105937f6d24cb8d767c7179fa55798e61a599e173c13 SHA512 ec23f7b5b2e2b109a753e12f1cb01377db52716600fbb31ca5b9a749e9d98e0eb60942b272c25a42efcb56add016310c79eda2c7385a3e0fc18e563f2f486d1e
DIST xdebug-2.9.8.tar.gz 438295 BLAKE2B 8645052faceb354817ddb448f46af5b849507d31255b43ac59bcef4ece7837ef835ae2ad624ed8a95f8f98d552ef0e7195a4ade7df9176bc300d855a0156f405 SHA512 c431d51a0d9c5ac1c7fc529c2819db480cbfff6f65c35c3c0dbef4e78427aa28ede164f397f92c409e58e386a6be34ecd2ded0ee35e01df1cbf92a49fd2f2aab
+DIST xdebug-3.0.1.tar.gz 432140 BLAKE2B f326de9a24c7c766b0f49213625ab7c455f7fd564af1848f2acb728fe513457140ee9669a05ddf83fd4ca07ecd591896d06bd570b60319178b484eaa7664cf88 SHA512 c50dea2abcad9c7e78ad7b7600a71c1bf0543c5fa31280a41c2acad2423bb6af8160e9d6b1e653f350f20660cfb2d8e4de07ae8f1181a465cc858dec13331c67
diff --git a/dev-php/xdebug/files/3.0-xdebug.ini b/dev-php/xdebug/files/3.0-xdebug.ini
new file mode 100644
index 000000000000..ed95a1214d97
--- /dev/null
+++ b/dev-php/xdebug/files/3.0-xdebug.ini
@@ -0,0 +1,41 @@
+;xdebug.cli_color = 0
+;xdebug.client_discovery_header =
+;xdebug.client_host = localhost
+;xdebug.client_port = 9003
+;xdebug.collect_params = 0
+;xdebug.collect_return = 0
+;xdebug.connect_timeout_ms = 200
+;xdebug.discover_client_host = 0
+;xdebug.dump.* = Empty
+;xdebug.dump_globals = 1
+;xdebug.dump_once = 1
+;xdebug.dump_undefined = 0
+;xdebug.file_link_format =
+;xdebug.filename_format = ...%s%n
+;xdebug.force_display_errors = 0
+;xdebug.force_error_reporting = 0
+;xdebug.gc_stats_output_name = gcstats.%p
+;xdebug.halt_level = 0
+;xdebug.idekey = *complex*
+;xdebug.log =
+;xdebug.log_level = 7
+;xdebug.max_nesting_level = 256
+;xdebug.max_stack_frames = -1
+xdebug.mode=off
+;xdebug.output_dir = /tmp
+;xdebug.profiler_append = 0
+;xdebug.profiler_output_name = cachegrind.out.%p
+;xdebug.scream = 0
+;xdebug.show_error_trace = 0
+;xdebug.show_exception_trace = 0
+;xdebug.show_local_vars = 0
+;xdebug.start_upon_error = default
+;xdebug.start_with_request = default
+;xdebug.trace_format = 0
+;xdebug.trace_options = 0
+;xdebug.trace_output_dir = /tmp
+;xdebug.trace_output_name = trace.%c
+;xdebug.trigger_value = ""
+;xdebug.var_display_max_children = 128
+;xdebug.var_display_max_data = 512
+;xdebug.var_display_max_depth = 3
diff --git a/dev-php/xdebug/xdebug-3.0.1.ebuild b/dev-php/xdebug/xdebug-3.0.1.ebuild
new file mode 100644
index 000000000000..26eee1e35033
--- /dev/null
+++ b/dev-php/xdebug/xdebug-3.0.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PHP_EXT_NAME="xdebug"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="yes"
+PHP_EXT_INIFILE="3.0-xdebug.ini"
+
+USE_PHP="php7-2 php7-3 php7-4 php8-0"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+inherit php-ext-source-r3
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="A PHP debugging and profiling extension"
+HOMEPAGE="https://xdebug.org/"
+# Using tarball from GitHub for tests
+#SRC_URI="https://pecl.php.net/get/${PN}-${MY_PV}.tgz"
+SRC_URI="https://github.com/xdebug/xdebug/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE=""
+
+# Tests are known to fail
+RESTRICT="test"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+DOCS=( README.rst CREDITS )
+PHP_EXT_ECONF_ARGS=()
+
+src_test() {
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ TEST_PHP_EXECUTABLE="${PHPCLI}" \
+ TEST_PHP_CGI_EXECUTABLE="${PHPCGI}" \
+ TEST_PHPDBG_EXECUTABLE="${PHPCLI}dbg" \
+ "${PHPCLI}" run-xdebug-tests.php
+ done
+}
+
+pkg_postinst() {
+ ewarn "We have set xdebug.mode to off, as xdebug can be"
+ ewarn "installed as a dependency, and not all users will want xdebug to be"
+ ewarn "enabled by default. If you want to enable it, you should edit the"
+ ewarn "ini file and set xdebug.mode to one or more modes e.g. develop,debug,trace"
+ elog ""
+ elog "The 3.0 major release changes many options."
+ elog "Review https://xdebug.org/docs/upgrade_guide for differences from 2.x"
+}