summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/3to2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/3to2')
-rw-r--r--dev-python/3to2/3to2-1.0.ebuild23
-rw-r--r--dev-python/3to2/3to2-1.1.1.ebuild25
-rw-r--r--dev-python/3to2/Manifest2
-rw-r--r--dev-python/3to2/metadata.xml12
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/3to2/3to2-1.0.ebuild b/dev-python/3to2/3to2-1.0.ebuild
new file mode 100644
index 000000000000..20208263e15b
--- /dev/null
+++ b/dev-python/3to2/3to2-1.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python2_7)
+inherit distutils-r1
+
+DESCRIPTION="Refactors valid 3.x syntax into valid 2.x syntax, if a syntactical conversion is possible"
+HOMEPAGE="http://pypi.python.org/pypi/3to2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ # the standard test runner fails to properly return failure
+ "${PYTHON}" -m unittest discover || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/3to2/3to2-1.1.1.ebuild b/dev-python/3to2/3to2-1.1.1.ebuild
new file mode 100644
index 000000000000..f7120694405e
--- /dev/null
+++ b/dev-python/3to2/3to2-1.1.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4})
+inherit distutils-r1
+
+DESCRIPTION="Refactors valid 3.x syntax into valid 2.x syntax, if a syntactical conversion is possible"
+HOMEPAGE="http://pypi.python.org/pypi/3to2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ # the standard test runner fails to properly return failure
+ "${PYTHON}" -m unittest discover || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/3to2/Manifest b/dev-python/3to2/Manifest
new file mode 100644
index 000000000000..caf4972d8d4b
--- /dev/null
+++ b/dev-python/3to2/Manifest
@@ -0,0 +1,2 @@
+DIST 3to2-1.0.tar.gz 46028 SHA256 1c5179e0ff3a1270e98aa213035185298392693a692a5e9053cea3c45e220182 SHA512 0f1eb0397e3e777a88a9530472349febaa36a5ddf45b000da174e8cb073dada65c3db566785550b2fa812651a1b2651fcbd281b29e3a3a8f6429379cd66536f0 WHIRLPOOL 970004480bd9abe48ce17527774b594bf25ed932eed96c9219786325783eba8ace8420db1598c615e1183907424d2b2f5a84c690d1341fee658aa440505200b7
+DIST 3to2-1.1.1.zip 78779 SHA256 fef50b2b881ef743f269946e1090b77567b71bb9a9ce64b7f8e699b562ff685c SHA512 7580f174409420556f89ae78eba07cc95b95aee9d062586d0862bd41980ae31bf4ac82a43855e160eec745fcdd3b4aff614f68e77da1bfc5f9f404413cab1492 WHIRLPOOL 39b8b8c2da3f759c93488888d4ccf9eae123302a5b7ae5861fdf4ad1be75a31e57dc752e382cb3ebc49b46921ab12d95d7837948e78c3c96dd98f4701805bf14
diff --git a/dev-python/3to2/metadata.xml b/dev-python/3to2/metadata.xml
new file mode 100644
index 000000000000..d64659c2f2b8
--- /dev/null
+++ b/dev-python/3to2/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">3to2</remote-id>
+ </upstream>
+</pkgmetadata>