summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-08-27 04:49:44 -0400
committerTim Harder <radhermit@gentoo.org>2017-08-27 04:53:49 -0400
commitf0b3f663f8a43c780b7b779afe6744af9b751c7b (patch)
tree65ace948c938f212df7cfe2eddb068903374c61b /dev-python/Babel/Babel-2.5.0.ebuild
parentdev-python/idna: version bump to 2.6 (diff)
downloadgentoo-f0b3f663f8a43c780b7b779afe6744af9b751c7b.tar.gz
gentoo-f0b3f663f8a43c780b7b779afe6744af9b751c7b.tar.bz2
gentoo-f0b3f663f8a43c780b7b779afe6744af9b751c7b.zip
dev-python/Babel: version bump to 2.5.0
Diffstat (limited to 'dev-python/Babel/Babel-2.5.0.ebuild')
-rw-r--r--dev-python/Babel/Babel-2.5.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/Babel/Babel-2.5.0.ebuild b/dev-python/Babel/Babel-2.5.0.ebuild
new file mode 100644
index 000000000000..9ec087d4bd7e
--- /dev/null
+++ b/dev-python/Babel/Babel-2.5.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of tools for internationalizing Python applications"
+HOMEPAGE="http://babel.edgewall.org/ https://pypi.python.org/pypi/Babel"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc test"
+
+RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Make the tests use implementation-specific datadir,
+ # because they try to write in it.
+ sed -e '/datadir =/s:os\.path\.dirname(__file__):os.environ["BUILD_DIR"]:' \
+ -i tests/messages/test_frontend.py || die
+ sed -e '/^intersphinx_mapping/,+3d' -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # Create implementation-specific datadir for tests.
+ cp -R -l tests/messages/data "${BUILD_DIR}"/ || die
+ py.test || die
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}