summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2017-01-22 23:03:23 +0700
committerAndrey Grozin <grozin@gentoo.org>2017-01-22 23:04:59 +0700
commitf6f284a24283abe627f12641ff3c9443f40018be (patch)
tree273f85f1cd97ddb27796cfdd35214f1bc8682bca /dev-python/BitVector/BitVector-3.4.6.ebuild
parentgames-board/pokerth: Remove old (diff)
downloadgentoo-f6f284a24283abe627f12641ff3c9443f40018be.tar.gz
gentoo-f6f284a24283abe627f12641ff3c9443f40018be.tar.bz2
gentoo-f6f284a24283abe627f12641ff3c9443f40018be.zip
dev-python/BitVector: bump to 3.4.6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/BitVector/BitVector-3.4.6.ebuild')
-rw-r--r--dev-python/BitVector/BitVector-3.4.6.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/BitVector/BitVector-3.4.6.ebuild b/dev-python/BitVector/BitVector-3.4.6.ebuild
new file mode 100644
index 000000000000..05c03159bd20
--- /dev/null
+++ b/dev-python/BitVector/BitVector-3.4.6.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure-Python memory-efficient packed representation for bit arrays"
+HOMEPAGE="http://cobweb.ecn.purdue.edu/~kak/dist/ https://pypi.python.org/pypi/BitVector"
+SRC_URI="http://cobweb.ecn.purdue.edu/~kak/dist/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+python_test() {
+ "${PYTHON}" TestBitVector/Test.py || die "Tests fail with ${EPYTHON}"
+}