summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-08-01 22:06:24 +0200
committerMichał Górny <mgorny@gentoo.org>2017-08-01 22:06:53 +0200
commit442e60ad267a13a357c5f2daa5db5095db47ac68 (patch)
tree844c2dd5a0abba6e53ecf6e80bef46842b316066 /dev-python/CommonMark
parentdev-python/pyopenssl: Tested on pypy & pypy3 (diff)
downloadgentoo-442e60ad267a13a357c5f2daa5db5095db47ac68.tar.gz
gentoo-442e60ad267a13a357c5f2daa5db5095db47ac68.tar.bz2
gentoo-442e60ad267a13a357c5f2daa5db5095db47ac68.zip
dev-python/CommonMark: Bump to 0.7.3
Diffstat (limited to 'dev-python/CommonMark')
-rw-r--r--dev-python/CommonMark/CommonMark-0.7.3.ebuild31
-rw-r--r--dev-python/CommonMark/Manifest1
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/CommonMark/CommonMark-0.7.3.ebuild b/dev-python/CommonMark/CommonMark-0.7.3.ebuild
new file mode 100644
index 000000000000..95f715545b5d
--- /dev/null
+++ b/dev-python/CommonMark/CommonMark-0.7.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python parser for the CommonMark Markdown spec"
+HOMEPAGE="https://github.com/rtfd/CommonMark-py"
+LICENSE="BSD"
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE=""
+RDEPEND="
+ dev-python/future[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ PYTHONIOENCODING='utf8' \
+ esetup.py test
+}
diff --git a/dev-python/CommonMark/Manifest b/dev-python/CommonMark/Manifest
index 0df81f3c9689..8f4c8d70ce56 100644
--- a/dev-python/CommonMark/Manifest
+++ b/dev-python/CommonMark/Manifest
@@ -1 +1,2 @@
DIST CommonMark-0.5.4.tar.gz 120316 SHA256 34d73ec8085923c023930dfc0bcd1c4286e28a2a82de094bb72fabcc0281cbe5 SHA512 1983714a50a627f30f86af0d02dad9e52cb7b0ffce29691d0e740f587e599ead6de2412d72b895b7df772e1c81e171e56dfecaf593e611af65bd5798632a98ad WHIRLPOOL f375b772faff450af98d73b3559dabe7b7369951cd8cf9ea45046bf5de875022212b7e92daee3fa7d3fb63d44894a301991a4561ac8a8b0c78eef64c83062fad
+DIST CommonMark-0.7.3.tar.gz 85177 SHA256 5f20ebd91614c8d339d4cded314894feb5d9a54c3b52c1ff9883794557149ea8 SHA512 34ddf0539b54d79cd16356124a15e4f51076a7afdde78fbaa0cab06658279357c5523d89bdfa7d595d85da9df9b194491ddac22b78444b230f53298ffd11c8cf WHIRLPOOL 41b1da6e2c1479b8b47b048d529282a8618f455653ad88e65f1460c55c74ccb7df563e159470ae8d912deede190d5da18b88111420a0d48fe264724e993871ef