summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-08 19:53:43 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-08 19:58:55 +0100
commit264dcdcd1ba7890343589d12e3754a3ccc1d5e72 (patch)
tree6001d1f835d10d2244b6de17d30cbcaeaadb2f28 /dev-python/Faker
parentdev-python/ipdb: Bump to 0.13.6 (diff)
downloadgentoo-264dcdcd1ba7890343589d12e3754a3ccc1d5e72.tar.gz
gentoo-264dcdcd1ba7890343589d12e3754a3ccc1d5e72.tar.bz2
gentoo-264dcdcd1ba7890343589d12e3754a3ccc1d5e72.zip
dev-python/Faker: Bump to 6.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Faker')
-rw-r--r--dev-python/Faker/Faker-6.5.1.ebuild28
-rw-r--r--dev-python/Faker/Manifest1
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-6.5.1.ebuild b/dev-python/Faker/Faker-6.5.1.ebuild
new file mode 100644
index 000000000000..44adab5d87c2
--- /dev/null
+++ b/dev-python/Faker/Faker-6.5.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="https://github.com/joke2k/faker"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/text-unidecode-1.3[${PYTHON_USEDEP}]
+ !dev-ruby/faker"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/random2[${PYTHON_USEDEP}]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
diff --git a/dev-python/Faker/Manifest b/dev-python/Faker/Manifest
index d5da3fa86b67..f05b195ba9c2 100644
--- a/dev-python/Faker/Manifest
+++ b/dev-python/Faker/Manifest
@@ -1,2 +1,3 @@
DIST Faker-5.6.5.tar.gz 1058615 BLAKE2B 2a730b79ca11a80b33f5249541e2de68e5c53832fcd06891ce2e074dbca8aa21c657147e55725d37954cb997a2b1854b5c853449e7d58a71358b69fd2a36584f SHA512 1806eded3534602eb5c463ad030564edfe7c663952e62e943b809dd5d7c4e485b26c612e45f481b6125f6462d48215df065f2d3f30df67ab19699b6386a65b7b
DIST Faker-6.4.1.tar.gz 1073921 BLAKE2B 1434375b8341ad3143e5977b26fd22af69aee2e30da92072937308341f22151764c8a72361c93112b5818dc9858e8e565ab2b45bd0fabc9e59613c1015e6ea63 SHA512 8ae2014b27f07b41afc67dc9a3d65e39f1073987c0c4bac6da5d625145e1d43783e4134bafdfe4e94035be9ff4367e5a19ab63635bf8ce7ff353a8745cf96269
+DIST Faker-6.5.1.tar.gz 1074618 BLAKE2B dfcd80c170ae1f68c4eb541804b4f91c5c2821669e51d3231daa92c6b2818b30e6ff6a6328e5836f534a7d1ddd24d4b089adffc461e785642d7663088ba47251 SHA512 7681e9afa48f39c3a7dd41ef48e70025a4a225de3cbb6b8272279f353df7d4b956a2398ae0d84926fc1e72530accda4b2407e1b0cee116494bccfbaaf21bc38d