summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-24 10:04:35 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-24 10:20:29 +0200
commit2cec945df44f21e43317cc2c5c51b44af1ba773e (patch)
treeb9abe2ac8b7f983af66998cd70b2b9d4cad58598 /dev-python/Faker
parentdev-python/sortedcontainers: Remove old (diff)
downloadgentoo-2cec945df44f21e43317cc2c5c51b44af1ba773e.tar.gz
gentoo-2cec945df44f21e43317cc2c5c51b44af1ba773e.tar.bz2
gentoo-2cec945df44f21e43317cc2c5c51b44af1ba773e.zip
dev-python/Faker: Bump to 8.8.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Faker')
-rw-r--r--dev-python/Faker/Faker-8.8.2.ebuild28
-rw-r--r--dev-python/Faker/Manifest1
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-8.8.2.ebuild b/dev-python/Faker/Faker-8.8.2.ebuild
new file mode 100644
index 000000000000..53094317ba83
--- /dev/null
+++ b/dev-python/Faker/Faker-8.8.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="https://github.com/joke2k/faker"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/text-unidecode-1.3[${PYTHON_USEDEP}]
+ !dev-ruby/faker"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/random2[${PYTHON_USEDEP}]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
diff --git a/dev-python/Faker/Manifest b/dev-python/Faker/Manifest
index 54e8a1f33206..ac859d9a3167 100644
--- a/dev-python/Faker/Manifest
+++ b/dev-python/Faker/Manifest
@@ -3,3 +3,4 @@ DIST Faker-8.6.0.tar.gz 1147647 BLAKE2B 6d3903ec2d75bae963879485572f7781455ff241
DIST Faker-8.7.0.tar.gz 1147940 BLAKE2B 9f0548472aa3ac092c2cf63da73fc456207da9ff4e405373ff7d2c8e02afff75912e1c3ac03a1d87981d66dfdb7ca611ae9ab2c8638c610032486e09ea37930f SHA512 cd75674aa959854701d2ba47f5f0638be730dbe1e4e6a6f9d551b100a65b8fc53cd9a5b1568a473bcf7c8044d2a3bd4ce7b621c8e7bc0bf002a5eb5afa5a6b96
DIST Faker-8.8.0.tar.gz 1148063 BLAKE2B e774e208438f7f31331c8c18bee2e7f27c2bb4e8f280bbdbd87e9de6484f5db9b38cfa01932efbbfdc82fc0bd3a8f05a9ade0324578deec750bb576b21f9ba7d SHA512 fc389638be46e109df208e8a6109e2236acfda136ccb7b02df9b4ef793310f63d9317f12b84811290851517afb557a130a4ed370176ef19e76d1e83b06959381
DIST Faker-8.8.1.tar.gz 1148431 BLAKE2B afb6fe9c3c93e909c26e734558d95186d3dff19efceee3a2bd7bb2158dfac34fc74c959ad163eb8e08f374d47c84bb454ffe45efa30b4b62e9d9e478ac784025 SHA512 46b1d04c40d93b8688421eb3dcfe6f718f61225d6e30846c9d6578c12451a2a1634a36bd084078e992174c9c017865b5acbbbda49d311b67f921ade14a72475f
+DIST Faker-8.8.2.tar.gz 1148529 BLAKE2B 279984479ad4f790dc7acd74b5ccd1cf5f32689b8b1ccf2152d7dfaa6fc7b4699d9827c16f83bb86e298723b6906a5cc40c2fa7f75439b5af5fc78c1af99a3f6 SHA512 4273008bf9ab693a40da2f93ff1fe40e9e7b102a2d5439f09096b6754b82dc26310666da65723b363f628365c97d44dd290e1e7065b7a9d862130baa292325b7