summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/GridDataFormats
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/GridDataFormats')
-rw-r--r--dev-python/GridDataFormats/GridDataFormats-0.2.2.ebuild23
-rw-r--r--dev-python/GridDataFormats/GridDataFormats-0.2.5.ebuild23
-rw-r--r--dev-python/GridDataFormats/Manifest2
-rw-r--r--dev-python/GridDataFormats/metadata.xml12
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/GridDataFormats/GridDataFormats-0.2.2.ebuild b/dev-python/GridDataFormats/GridDataFormats-0.2.2.ebuild
new file mode 100644
index 000000000000..e445b9bc2db0
--- /dev/null
+++ b/dev-python/GridDataFormats/GridDataFormats-0.2.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Reading and writing of data on regular grids in Python"
+HOMEPAGE="https://pypi.python.org/pypi/GridDataFormats"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/numpy-1.0.3[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]"
diff --git a/dev-python/GridDataFormats/GridDataFormats-0.2.5.ebuild b/dev-python/GridDataFormats/GridDataFormats-0.2.5.ebuild
new file mode 100644
index 000000000000..68462ade6c18
--- /dev/null
+++ b/dev-python/GridDataFormats/GridDataFormats-0.2.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Reading and writing of data on regular grids in Python"
+HOMEPAGE="https://pypi.python.org/pypi/GridDataFormats https://github.com/MDAnalysis/GridDataFormats"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/numpy-1.0.3[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]"
diff --git a/dev-python/GridDataFormats/Manifest b/dev-python/GridDataFormats/Manifest
new file mode 100644
index 000000000000..8f1f30cc5235
--- /dev/null
+++ b/dev-python/GridDataFormats/Manifest
@@ -0,0 +1,2 @@
+DIST GridDataFormats-0.2.2.tar.gz 42363 SHA256 8305897bb291b5cd4e6513e54225f149fab2f5ad13b3437dff77aa6d6c02a383 SHA512 671ed6da8a4447f90f6a95b8fdec53ba793134bbe0adac0b12d97b66ea7e36754a14b64a21926438e8c901d7e9171e56a82fab8d8989fa09fa6bae512bbac229 WHIRLPOOL 2a2bdb3267faed86264297bb5933af7b2d3308587341c905bc091d214dfa9d11bdce3b9efc7c13baae234a291d93374f38326bd8585c75c0de0fe8848414c17b
+DIST GridDataFormats-0.2.5.tar.gz 40725 SHA256 f13d8412433d625fa8dfb17152f3593ec5364f771d2157a387f1abda9d1eeefb SHA512 aa16f9046855417f9878b8f7d59fd7ec96025f7c4696c6025fad520f55a5684881966ba3e8a6189c746dcfb57ac969ed62acdcc38d758fe6bea1b20d45b8fa85 WHIRLPOOL a80f19025c01a76f937d636d4d18dad1604a6a60f7cac27aacec5d6d0f81cbd077d01e702dffeae2e8429746465c185def42380a967cc9c08c9049fb065e01f0
diff --git a/dev-python/GridDataFormats/metadata.xml b/dev-python/GridDataFormats/metadata.xml
new file mode 100644
index 000000000000..f73931c612f7
--- /dev/null
+++ b/dev-python/GridDataFormats/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">GridDataFormats</remote-id>
+ <remote-id type="github">MDAnalysis/GridDataFormats</remote-id>
+ </upstream>
+</pkgmetadata>