summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-05 08:11:24 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-05 08:19:07 +0200
commitd222bb1a7d065a7a9972fa4e1b5d9bb7bf310939 (patch)
tree372f4264481ee06c02a688cb4968e5eb8aac0ca1 /dev-python/MechanicalSoup
parentdev-python/tifffile: Bump to 2023.7.4 (diff)
downloadgentoo-d222bb1a7d065a7a9972fa4e1b5d9bb7bf310939.tar.gz
gentoo-d222bb1a7d065a7a9972fa4e1b5d9bb7bf310939.tar.bz2
gentoo-d222bb1a7d065a7a9972fa4e1b5d9bb7bf310939.zip
dev-python/MechanicalSoup: Bump to 1.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/MechanicalSoup')
-rw-r--r--dev-python/MechanicalSoup/Manifest1
-rw-r--r--dev-python/MechanicalSoup/MechanicalSoup-1.3.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/MechanicalSoup/Manifest b/dev-python/MechanicalSoup/Manifest
index 5516c20be158..be96f4e7509d 100644
--- a/dev-python/MechanicalSoup/Manifest
+++ b/dev-python/MechanicalSoup/Manifest
@@ -1 +1,2 @@
DIST MechanicalSoup-1.2.0.tar.gz 49669 BLAKE2B a9791fd2d389c8a553ed0acce179094770651553b7aaf299ec6779509b4ffb1bb97a4a4afe01af3e4ccb56cf100b5bacc39e9aedf1143a9eb6f4b98dbb020062 SHA512 5857274e07c678dc0e19ad4fef828ccf41bb846edad566c2da9914144ced8802efd546265efac792acbb885b29cab5cde4ac3cd2002826a8bb31f91004eb2caa
+DIST MechanicalSoup-1.3.0.tar.gz 50826 BLAKE2B c47760a0f8d9c7a6430580c81fb750d3eab37a773a7453fb2850396ea2cff1ae143b1ec9ec5e1d8051a52f39c1527b99126f4ea2c90a73c7730597dd92a42a11 SHA512 a205c9b36b540be8b3eb15803c34e67029cb5b33aaf36d235947cc46c588f2d63e68acd97a9872b20ad3f1c87dcdb6133b4860dc7d90752ac477aaaa9a7c3e82
diff --git a/dev-python/MechanicalSoup/MechanicalSoup-1.3.0.ebuild b/dev-python/MechanicalSoup/MechanicalSoup-1.3.0.ebuild
new file mode 100644
index 000000000000..2d889dc6917a
--- /dev/null
+++ b/dev-python/MechanicalSoup/MechanicalSoup-1.3.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( pypy3 python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python library for automating interaction with websites"
+HOMEPAGE="
+ https://github.com/MechanicalSoup/MechanicalSoup/
+ https://pypi.org/project/MechanicalSoup/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/beautifulsoup4-4.7[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.22.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/requests-mock-1.3.0[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_test() {
+ epytest -o addopts=
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}