summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-11 21:10:17 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-11 21:20:32 +0100
commit39bfa17ba58f343e69d8545c912739e064237e24 (patch)
tree473e29d4f3cf811bd12b233fbfa2944bdbab2424 /dev-python/Nuitka
parentdev-python/toposort: Bump to 1.9 (diff)
downloadgentoo-39bfa17ba58f343e69d8545c912739e064237e24.tar.gz
gentoo-39bfa17ba58f343e69d8545c912739e064237e24.tar.bz2
gentoo-39bfa17ba58f343e69d8545c912739e064237e24.zip
dev-python/Nuitka: Bump to 1.3.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Nuitka')
-rw-r--r--dev-python/Nuitka/Manifest1
-rw-r--r--dev-python/Nuitka/Nuitka-1.3.7.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/Nuitka/Manifest b/dev-python/Nuitka/Manifest
index 040634807a17..98b798700bfb 100644
--- a/dev-python/Nuitka/Manifest
+++ b/dev-python/Nuitka/Manifest
@@ -1,3 +1,4 @@
DIST Nuitka-1.3.4.tar.gz 4028710 BLAKE2B 5cf02644524f612cd4403147323ce0e4d121efd91d8a9da3f55e81117e088337ce9d56f801691b52236bb17bb7ffc3987e98c8d23bad1c84b4bae61fae41b5cd SHA512 7c3562a264833ba2b5ed09a43d91113f59ece8a088480ac03517fe66b380d354faf465845fb7218d34f328114d8bdee92d4374651182f85f50593ce9294e8796
DIST Nuitka-1.3.5.tar.gz 4019765 BLAKE2B dc169a318400e23021a2712f41c49e8d045352c2b6ab946a289d479ee3aeb887456cb0218e762ea091885ce4204d1c3d59e6d228a58b596a70387400e5f31c35 SHA512 edc603b3b38e68473d3002641e61d969cd1fe9626aaa45023c017b2c2ed288d61ee5e537e9b96ca53efc5e052e689df37849bb0b1da65d0b31d38152645ced25
DIST Nuitka-1.3.6.tar.gz 4029420 BLAKE2B 2c4f9daeb8532287e0e1ff65bcb6da77a048ea4638b74c4f7fe86bcc2d2a2746357af264bf0659ce3a582f270dda049d750050482eb65c4582387ffcd788a9f5 SHA512 c8ec015b9cdf2a49b5cc31103ff14d47654c7df3f003fc045a6b41df11b48597975427cc38c5f03b7b2e9f57e7838ccbc2def168943069be4bafe28a2e1c921e
+DIST Nuitka-1.3.7.tar.gz 4029412 BLAKE2B daa123ff224d442bc5afe251cf2658945a8cf7ca2c173307da81a72cf915c7110958bb7650b9bc2d3ff98f6867530554125b37d3f1e30d5bd784f648e8da785d SHA512 afff1e77bdce22ce41ca0d9824392f2319ab7b9754d26a00f6001bab09402d8f8665a921077d4e08958e4508fb922c833e4c16d25a04da6925a84a96cee0a87c
diff --git a/dev-python/Nuitka/Nuitka-1.3.7.ebuild b/dev-python/Nuitka/Nuitka-1.3.7.ebuild
new file mode 100644
index 000000000000..3ad289dde538
--- /dev/null
+++ b/dev-python/Nuitka/Nuitka-1.3.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_10 )
+
+inherit distutils-r1 flag-o-matic optfeature
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://www.nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-util/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}