summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-24 08:30:20 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-24 08:41:09 +0100
commit6b9ad4857869dc478ae4ec4a39b406fcd2aa81a2 (patch)
treeb3ad677b44912a3b8d5e6e998f67e5030f187b1b /dev-python/Nuitka
parentdev-python/weasyprint: Bump to 57.2 (diff)
downloadgentoo-6b9ad4857869dc478ae4ec4a39b406fcd2aa81a2.tar.gz
gentoo-6b9ad4857869dc478ae4ec4a39b406fcd2aa81a2.tar.bz2
gentoo-6b9ad4857869dc478ae4ec4a39b406fcd2aa81a2.zip
dev-python/Nuitka: Bump to 1.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Nuitka')
-rw-r--r--dev-python/Nuitka/Manifest1
-rw-r--r--dev-python/Nuitka/Nuitka-1.3.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/Nuitka/Manifest b/dev-python/Nuitka/Manifest
index f048be1aea42..f19b7dedec97 100644
--- a/dev-python/Nuitka/Manifest
+++ b/dev-python/Nuitka/Manifest
@@ -1,3 +1,4 @@
DIST Nuitka-1.2.6.tar.gz 3959091 BLAKE2B b326409f49d722bcac7df3e2c5caae7fb9ccf2b2991d2cf003a4db7bd268af95b7423da3b69b93b45c2aa1e3461faac90872b01f2d2277c5e9f7c71bedb0df56 SHA512 b12f694f8ac26213fd1242c66c2a37be1940bafef8a4949f0e401f056a1f72a010d1df237a828317ed0c88530206c31e617f03e4bccf6c934b967f8ddaef330f
DIST Nuitka-1.2.7.tar.gz 3960368 BLAKE2B 582ad7f7a96577fd87a4f9fe083d90f532f2ddd7824b4105d258551b559d9390fba428b80223c6ca4d00eda451cc21a63449c7370a3e43d4b7f9a28fc6bba4c9 SHA512 37a3c29614102dc80f916ac483a6e87322b7a3b9cf25355bdf2f29d84e33300640607fcb7fdc6a338431bc890b4337512c43368e47a2d69c7254b7b7794bb35b
DIST Nuitka-1.3.1.tar.gz 4028497 BLAKE2B 877413970a1e169abe8b9770d927d2e9a33bcd775466adc7287fdcc8f69d412fae249ea96a16aca4166d655f1a016852e06018f55c0b62afe4b53c5b1c540870 SHA512 09f8ff13f14af20ee2fa8b80714ff52a3bc2a36658113e122ba383f34e9ca8c27af42b14cb06477e3a2ed2e5dfa60e10295c4f96a209db699719c456518c464d
+DIST Nuitka-1.3.2.tar.gz 4019850 BLAKE2B fce2015b1af9e0b93b777982c772aaa903145bc55a5effb68ba581a31f63e34280aace47df8292d2125725dee02c55c1d54580a08d2d8d3a775459edb9807837 SHA512 5a1713757a6b1347320accc717a01b2abfb3b815683880845fb35ec92e7c94bd7e011a83bd16ed1ba28d14f4128945bdd89d39b89fe8dc7a59c69e9f127bc4b6
diff --git a/dev-python/Nuitka/Nuitka-1.3.2.ebuild b/dev-python/Nuitka/Nuitka-1.3.2.ebuild
new file mode 100644
index 000000000000..6ba48aa72091
--- /dev/null
+++ b/dev-python/Nuitka/Nuitka-1.3.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_10 )
+
+inherit distutils-r1 flag-o-matic optfeature
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://www.nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-util/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}