summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-04 09:39:11 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-04 09:39:52 -0500
commit985674aa671567135d601e5e3ea82800db1fa46d (patch)
tree9996dd7d42b66d5244e743c39d414fdbc19fa7d3 /dev-python/PyECLib
parentapp-crypt/certbot-nginx: 0.33.0 bump (diff)
downloadgentoo-985674aa671567135d601e5e3ea82800db1fa46d.tar.gz
gentoo-985674aa671567135d601e5e3ea82800db1fa46d.tar.bz2
gentoo-985674aa671567135d601e5e3ea82800db1fa46d.zip
dev-python/PyECLib: 1.6.0 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/PyECLib')
-rw-r--r--dev-python/PyECLib/Manifest1
-rw-r--r--dev-python/PyECLib/PyECLib-1.6.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/PyECLib/Manifest b/dev-python/PyECLib/Manifest
index 2c9b700b66f7..907335f12e4b 100644
--- a/dev-python/PyECLib/Manifest
+++ b/dev-python/PyECLib/Manifest
@@ -1 +1,2 @@
DIST pyeclib-1.5.0.tar.gz 6682493 BLAKE2B 3f3a595b67a8e216b90c61f8119be6f40de0863a0d77c4e65c41e699aad0d9a5f1d621e8bb9510d78b9eb495acc5fc5af7178afe127780151b9be60ca246fbff SHA512 89831fc8b04a1488504b632f75da8f2f29bc6b4e33b35d0d4305b4d5ec4bc25c0e16d149580badb15be7dbf8aeb2bdebef81f78f7b7871233afaaf96823e3a3e
+DIST pyeclib-1.6.0.tar.gz 6685306 BLAKE2B 0b758bd500afc7f9d8e38513cc41f1916413d8ad6f3b1bd34d9ff46d6d33321391eaf90164e412154a14d63d4ba61502457bb943e124dd7054a5d5ec20732294 SHA512 507f78388e941e4600f4b77f636ce27b7f63e635f108dd5a452b3f98f779e87d94d8f82239d9d5733846faa5cc574c0474e366d99e44b8f03b70707d352f56c8
diff --git a/dev-python/PyECLib/PyECLib-1.6.0.ebuild b/dev-python/PyECLib/PyECLib-1.6.0.ebuild
new file mode 100644
index 000000000000..ab29e70bcb74
--- /dev/null
+++ b/dev-python/PyECLib/PyECLib-1.6.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils multilib
+
+DESCRIPTION="Messaging API for RPC and notifications over different messaging transports"
+HOMEPAGE="https://pypi.org/project/PyECLib/"
+SRC_URI="mirror://pypi/p/pyeclib/pyeclib-${PV}.tar.gz"
+S="${WORKDIR}/pyeclib-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDEPEND="dev-libs/jerasure"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="dev-libs/liberasurecode
+ ${CDEPEND}"