summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorXavier Forestier <xavier.forestier@free.fr>2016-10-28 23:06:02 +1100
committerMichael Palimaka <kensington@gentoo.org>2016-10-28 23:08:16 +1100
commit24c516062ddd7464a454b932f001b55759035e57 (patch)
tree2386deb1bc86bcb487719eda87b5195a270833b9 /dev-python/PyQt5
parentsys-kernel/gentoo-sources: Linux patch 4.1.35 (diff)
downloadgentoo-24c516062ddd7464a454b932f001b55759035e57.tar.gz
gentoo-24c516062ddd7464a454b932f001b55759035e57.tar.bz2
gentoo-24c516062ddd7464a454b932f001b55759035e57.zip
dev-python/PyQt5: add patch to solve build failure with Qt 5.6.2
Gentoo-bug: 597302 Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-python/PyQt5')
-rw-r--r--dev-python/PyQt5/PyQt5-5.7.ebuild1
-rw-r--r--dev-python/PyQt5/files/PyQt5-5.7-qt-5.6.2.patch11
2 files changed, 12 insertions, 0 deletions
diff --git a/dev-python/PyQt5/PyQt5-5.7.ebuild b/dev-python/PyQt5/PyQt5-5.7.ebuild
index 2a87ef1b5aee..0990f7a6aa33 100644
--- a/dev-python/PyQt5/PyQt5-5.7.ebuild
+++ b/dev-python/PyQt5/PyQt5-5.7.ebuild
@@ -96,6 +96,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
DOCS=( "${S}"/{ChangeLog,NEWS} )
+PATCHES=( "${FILESDIR}/${P}-qt-5.6.2.patch" )
pyqt_use_enable() {
use "$1" || return
diff --git a/dev-python/PyQt5/files/PyQt5-5.7-qt-5.6.2.patch b/dev-python/PyQt5/files/PyQt5-5.7-qt-5.6.2.patch
new file mode 100644
index 000000000000..542f6d031ef4
--- /dev/null
+++ b/dev-python/PyQt5/files/PyQt5-5.7-qt-5.6.2.patch
@@ -0,0 +1,11 @@
+--- a/sip/QtCore/QtCoremod.sip
++++ b/sip/QtCore/QtCoremod.sip
+@@ -22,7 +22,7 @@
+
+ %Module(name=PyQt5.QtCore, call_super_init=True, default_VirtualErrorHandler=PyQt5, keyword_arguments="Optional", version=1)
+
+-%Timeline {Qt_5_0_0 Qt_5_0_1 Qt_5_0_2 Qt_5_1_0 Qt_5_1_1 Qt_5_2_0 Qt_5_2_1 Qt_5_3_0 Qt_5_3_1 Qt_5_3_2 Qt_5_4_0 Qt_5_4_1 Qt_5_4_2 Qt_5_5_0 Qt_5_5_1 Qt_5_6_0 Qt_5_6_1 Qt_5_7_0}
++%Timeline {Qt_5_0_0 Qt_5_0_1 Qt_5_0_2 Qt_5_1_0 Qt_5_1_1 Qt_5_2_0 Qt_5_2_1 Qt_5_3_0 Qt_5_3_1 Qt_5_3_2 Qt_5_4_0 Qt_5_4_1 Qt_5_4_2 Qt_5_5_0 Qt_5_5_1 Qt_5_6_0 Qt_5_6_1 Qt_5_6_2 Qt_5_7_0}
+
+ %Platforms {WS_X11 WS_WIN WS_MACX}
+