summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2019-12-07 09:20:32 +0100
committerFabian Groffen <grobian@gentoo.org>2019-12-07 09:20:32 +0100
commit1fd03dcdeaef5a301eea21adad4078726047b98a (patch)
tree135b3dcbe6dff0397f0cfc84ba5178a4a87d3843 /dev-python/PySensors
parentx11-misc/picom: add missing xcb part dependencies (diff)
downloadgentoo-1fd03dcdeaef5a301eea21adad4078726047b98a.tar.gz
gentoo-1fd03dcdeaef5a301eea21adad4078726047b98a.tar.bz2
gentoo-1fd03dcdeaef5a301eea21adad4078726047b98a.zip
dev-python/PySensors-0.0.4: version bump for Python 3 support
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'dev-python/PySensors')
-rw-r--r--dev-python/PySensors/Manifest1
-rw-r--r--dev-python/PySensors/PySensors-0.0.4.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/PySensors/Manifest b/dev-python/PySensors/Manifest
index a351f0ae7389..0f98bbc13f4a 100644
--- a/dev-python/PySensors/Manifest
+++ b/dev-python/PySensors/Manifest
@@ -1 +1,2 @@
DIST PySensors-0.0.3.tar.gz 5109 BLAKE2B 8d537c121540c8e28d0f8cfc45152abea0e312c48a460e877935c7d8639710c8046a96f598c724082870ad7c0d528621bce85d8616485336c2b4f8ac2ebe7579 SHA512 b9ae61ee9049e1edd3fdee7b122c0f9aa19677aee401c910fcaec5a6bc95a0628d6b7eb2b59f1d14196bee22395819f4980d328d60dd69b0a413f7d08041f159
+DIST PySensors-0.0.4.tar.gz 10599 BLAKE2B be3a3692a846e5339758eff4f4396dd15bf96b3d20bc40df45436ce58381ac87503bca190fa215121506ecf9ce5175b254d93142ee881c4d5b8ef8e045854659 SHA512 8e6b2beee9bf282f073618c0b45e53330ce82c9fc9c6565a3c6b5f812231421c8c6e15ccc4fc92cda67ed08df5c482577d4a34720c920dbba7604f2b7c3ba21c
diff --git a/dev-python/PySensors/PySensors-0.0.4.ebuild b/dev-python/PySensors/PySensors-0.0.4.ebuild
new file mode 100644
index 000000000000..4b2716c2ce5a
--- /dev/null
+++ b/dev-python/PySensors/PySensors-0.0.4.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_6 python3_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings to libsensors (via ctypes)"
+HOMEPAGE="https://pypi.org/project/PySensors/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">=sys-apps/lm-sensors-3"