summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-12-10 18:45:42 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-12-10 18:56:44 -0800
commite84a9b5f23a21dd21166826bebb9cb1a10183859 (patch)
tree5b49de7f37c7faa39d9148cfbc9324f8d3b200ce /dev-python/PyUtilib
parentdev-libs/libbpf-0.0.6: Version bump (diff)
downloadgentoo-e84a9b5f23a21dd21166826bebb9cb1a10183859.tar.gz
gentoo-e84a9b5f23a21dd21166826bebb9cb1a10183859.tar.bz2
gentoo-e84a9b5f23a21dd21166826bebb9cb1a10183859.zip
dev-python/PyUtilib-5.7.2: Version bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/PyUtilib')
-rw-r--r--dev-python/PyUtilib/Manifest1
-rw-r--r--dev-python/PyUtilib/PyUtilib-5.7.2.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/PyUtilib/Manifest b/dev-python/PyUtilib/Manifest
index 23ea8a4b8141..7920e7a33a59 100644
--- a/dev-python/PyUtilib/Manifest
+++ b/dev-python/PyUtilib/Manifest
@@ -1 +1,2 @@
DIST PyUtilib-5.6.5.tar.gz 1504220 BLAKE2B 2d00b8b9a0a787413dce5dd4380382efa4c8788e9a8f5188eb0decf9e55bc07ce5ceb8e6f32ed2fa7cf58c331fe936ea07d9b599ff8e7e9593327d3c0f05d4e9 SHA512 5e7f86c29ff81cfffea5862d09ec8d026739f09b172606acd4d08dc4a9bde28c8b63b8e51634d17c3161b46e7e8c8881050044baa22bc07b0926efe46ed7331d
+DIST PyUtilib-5.7.2.tar.gz 1566034 BLAKE2B 913c6576b39f14c19e2e633c36ade33fe812c77a37374c7c14d2fb4384ca38f68efd55209d70e96d9a78fea2fcf1cf83423680d0787da2d03cab88e59a208b96 SHA512 d9d7d890cdb524bb055885354784f2af01967164ce88cf3b144ccffb0a855ef34243fd518c58193517ecfc50f3c2e3ca333f026951c1ab0b38ce181ecf9e7750
diff --git a/dev-python/PyUtilib/PyUtilib-5.7.2.ebuild b/dev-python/PyUtilib/PyUtilib-5.7.2.ebuild
new file mode 100644
index 000000000000..2fc844c76ed3
--- /dev/null
+++ b/dev-python/PyUtilib/PyUtilib-5.7.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} )
+DISTUTILS_IN_SOURCE_BUILD=1
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of Python utilities"
+HOMEPAGE="https://github.com/PyUtilib/pyutilib"
+SRC_URI="https://github.com/${PN}/${PN,,}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN,,}-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/pyutilib-5.6.5-tests.patch"
+)
+
+python_prepare_all() {
+ # remove some tests that are completely broken
+ rm pyutilib/component/app/tests/test_simple.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+
+ local -x PYTHONPATH="${PWD}:${TEST_DIR}/lib" \
+ COLUMNS=80
+
+ nosetests -v --with-xunit --xunit-file=TEST-pyutilib.xml pyutilib || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ find "${ED}" -name '*.pth' -delete || die
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ if ! python_is_python3; then
+ printf "# Placeholder for python2\n" \
+ > "${D}$(python_get_sitedir)/${PN,,}/__init__.py"
+
+ python_optimize
+ fi
+}