summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-02 09:44:22 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-02 09:44:22 +0200
commit8dd62a5cb7b049a63d46c90c8e95cb43613685ee (patch)
treee48e61bb9a4c0b456a8320af38fcae811059dbd8 /dev-python/QtPy
parentsci-visualization/veusz: restrict to <dev-python/sip-5 (diff)
downloadgentoo-8dd62a5cb7b049a63d46c90c8e95cb43613685ee.tar.gz
gentoo-8dd62a5cb7b049a63d46c90c8e95cb43613685ee.tar.bz2
gentoo-8dd62a5cb7b049a63d46c90c8e95cb43613685ee.zip
dev-python/QtPy: fix flags for test dependencies
Since the test phase was rewritten in the previous commit to allow testing with only one of the implementations (in order to allow adding python3.10), we no longer have to pull in both implementations to run the test phase. Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/QtPy')
-rw-r--r--dev-python/QtPy/QtPy-1.9.0-r5.ebuild34
1 files changed, 19 insertions, 15 deletions
diff --git a/dev-python/QtPy/QtPy-1.9.0-r5.ebuild b/dev-python/QtPy/QtPy-1.9.0-r5.ebuild
index b2d2c09acca2..a2061df8a264 100644
--- a/dev-python/QtPy/QtPy-1.9.0-r5.ebuild
+++ b/dev-python/QtPy/QtPy-1.9.0-r5.ebuild
@@ -92,21 +92,25 @@ RDEPEND="
BDEPEND="
test? (
dev-python/mock[${PYTHON_USEDEP}]
- dev-python/PyQt5[${PYTHON_USEDEP}]
- dev-python/PyQt5[bluetooth,dbus,declarative,designer,gui,help,location]
- dev-python/PyQt5[multimedia,network,opengl,positioning,printsupport]
- dev-python/PyQt5[sensors,serialport,sql,svg,testlib,webchannel]
- dev-python/PyQt5[websockets,widgets,x11extras,xml(+),xmlpatterns]
- dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/pyside2[${PYTHON_USEDEP}]
- dev-python/pyside2[3d,charts,concurrent,datavis,designer,gui,help]
- dev-python/pyside2[location,multimedia,network,opengl(+),positioning]
- dev-python/pyside2[printsupport,qml,quick,script,scripttools,scxml]
- dev-python/pyside2[sensors,serialport(+),speech,sql,svg,testlib]
- dev-python/pyside2[webchannel,webengine,websockets,widgets,x11extras]
- dev-python/pyside2[xml,xmlpatterns]
- ' python3_{7..9} )
+ pyqt5? (
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+ dev-python/PyQt5[bluetooth,dbus,declarative,designer,gui,help,location]
+ dev-python/PyQt5[multimedia,network,opengl,positioning,printsupport]
+ dev-python/PyQt5[sensors,serialport,sql,svg,testlib,webchannel]
+ dev-python/PyQt5[websockets,widgets,x11extras,xml(+),xmlpatterns]
+ dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
+ )
+ pyside2? (
+ $(python_gen_cond_dep '
+ dev-python/pyside2[${PYTHON_USEDEP}]
+ dev-python/pyside2[3d,charts,concurrent,datavis,designer,gui,help]
+ dev-python/pyside2[location,multimedia,network,opengl(+),positioning]
+ dev-python/pyside2[printsupport,qml,quick,script,scripttools,scxml]
+ dev-python/pyside2[sensors,serialport(+),speech,sql,svg,testlib]
+ dev-python/pyside2[webchannel,webengine,websockets,widgets,x11extras]
+ dev-python/pyside2[xml,xmlpatterns]
+ ' python3_{7..9} )
+ )
)
"