summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-14 11:32:16 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-14 11:33:06 +0200
commitc97b37c3db7bd25043d5e1297f00abce5f4dc0e2 (patch)
tree85bf2488571bdaeff40aa22c93f706acc2d2e85c /dev-python/QtPy
parentdev-python/QtPy: add version 1.11.1 (diff)
downloadgentoo-c97b37c3db7bd25043d5e1297f00abce5f4dc0e2.tar.gz
gentoo-c97b37c3db7bd25043d5e1297f00abce5f4dc0e2.tar.bz2
gentoo-c97b37c3db7bd25043d5e1297f00abce5f4dc0e2.zip
dev-python/QtPy: drop version 1.11.0
Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/QtPy')
-rw-r--r--dev-python/QtPy/Manifest1
-rw-r--r--dev-python/QtPy/QtPy-1.11.0.ebuild158
2 files changed, 0 insertions, 159 deletions
diff --git a/dev-python/QtPy/Manifest b/dev-python/QtPy/Manifest
index 547c3fcc464e..2f2e5c04e36c 100644
--- a/dev-python/QtPy/Manifest
+++ b/dev-python/QtPy/Manifest
@@ -1,4 +1,3 @@
DIST QtPy-1.10.0.tar.gz 34339 BLAKE2B cbae5eb38bf8ee4ab1528bca0afa93c57b70f48eb44639eac04344f4bbef28a4277bd3727ed5ac25f8ef18cc5391fafd33bb8ea42037eabee10cd4d13d7d3d1c SHA512 5ca326ae64cc85b48b02daa344d23387a9165a0097d59c31d921c7f67141afe31dad8a46abd0b201b31446f97405d7dce4dacd936b24c5faf9484dc37665e974
-DIST QtPy-1.11.0.tar.gz 36855 BLAKE2B 6e505241a59fa0b5bf8b82a4de2ee0d8e04e56975a7bc9857af212d5511769d2819ea627fc30605f0459c566ca5a2fce4303a2e282c3230bf5a8155a326097b5 SHA512 589626bd61ec94a6c9c5eb0c436c4b96a5d387e7aa4e7ea22a5de6e9e6f73d2034cda0144783837e8bd4798cd6da1415b8478b2e92ff5fd826800bfbc0751859
DIST QtPy-1.11.1.tar.gz 37068 BLAKE2B 5eef91a8aaad5d8354d123481e434a2b32b1aa1eddd4b6cc0205a40249533c2f6211b13ea049485243e510b0d820c35f0f5833df4c42276d15f3f8269cff3604 SHA512 467780e353b9658234cc164a11bc1526165a31a2021fd75efdd109ea516de5f279bb601130c98fd295aba99c40f20ab3d2c4758951180d4dc05e47bbc3e8408c
DIST QtPy-1.9.0.tar.gz 35522 BLAKE2B 05b700c1f804cc535c3065c8f819d1d7fb0e02d43f199082d2e0d2c575ff8dbfdbf0053ddb3b155108cf55350ff4daf75166ab39a60374a35a86a1707724a4a1 SHA512 2492c531f0df3afc9e0f8875a2b2e39cc8b09542fb9f251900b8596c0db7767390bb85365cc39efd6cd37ae852a00655354e6f9f3d795023e4fd86dbf8bd5fa7
diff --git a/dev-python/QtPy/QtPy-1.11.0.ebuild b/dev-python/QtPy/QtPy-1.11.0.ebuild
deleted file mode 100644
index 7dee17becfaf..000000000000
--- a/dev-python/QtPy/QtPy-1.11.0.ebuild
+++ /dev/null
@@ -1,158 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Abstraction layer on top of PyQt5 and PySide2 and additional custom QWidgets"
-HOMEPAGE="https://github.com/spyder-ide/qtpy/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-_IUSE_QT_MODULES="
- declarative designer gui help location multimedia network opengl
- positioning printsupport sensors serialport speech sql svg testlib
- webchannel webengine websockets widgets x11extras xml xmlpatterns
-"
-IUSE="+pyqt5 pyside2 ${_IUSE_QT_MODULES}"
-unset _IUSE_QT_MODULES
-
-# PySide2 does not support python3_10, nor is it likely that it will in the
-# future since upstream appears to be focussing on PySide6 for Qt6 instead
-# (which is compatible with python3_10). So if we want to use python3_10
-# we have to force disable pyside2.
-REQUIRED_USE="
- || ( pyqt5 pyside2 )
- python_targets_python3_10? ( pyqt5 !pyside2 )
-"
-
-# These flags are currently *not* common to both the PySide2 and PyQt5 ebuild
-# Disable them for now, please check periodically if this is still up to date.
-# bluetooth? ( pyqt5 )
-# dbus? ( pyqt5 )
-#
-# 3d? ( pyside2 )
-# charts? ( pyside2 )
-# concurrent? ( pyside2 )
-# datavis? ( pyside2 )
-# scxml? ( pyside2 )
-# script? ( pyside2 )
-# scripttools? ( pyside2 )
-
-# WARNING: the obvious solution of using || for PyQt5/pyside2 is not going
-# to work. The package only checks whether PyQt5/pyside2 is installed, it does
-# not verify whether they have the necessary modules (i.e. satisfy the USE dep).
-#
-# Webengine is a special case, because PyQt5 provides this in a separate package
-# while PySide2 ships it in the same package.
-#
-# declarative/qml/quick is a special case, because PyQt5 bundles the bindings
-# for qml and quick in one flag: declarative PySide2 does not.
-#
-# The PyQt5 ebuild currently enables xml support unconditionally, the flag is
-# added anyway with a (+) to make it future proof if the ebuild were to change
-# this behaviour in the future.
-#
-# The PySide2 ebuild currently enables opengl and serialport support
-# unconditionally, the flag is added anyway with a (+) to make it future proof
-# if the ebuild were to change this behaviour in the future.
-RDEPEND="
- pyqt5? (
- dev-python/PyQt5[${PYTHON_USEDEP}]
- dev-python/PyQt5[declarative?,designer?,gui?,help?,location?]
- dev-python/PyQt5[multimedia?,network?,opengl?,positioning?]
- dev-python/PyQt5[printsupport?,sensors?,serialport?,speech(-)?,sql?,svg?]
- dev-python/PyQt5[testlib?,webchannel?,websockets?,widgets?]
- dev-python/PyQt5[x11extras?,xml(+)?,xmlpatterns?]
- webengine? ( dev-python/PyQtWebEngine[${PYTHON_USEDEP}] )
- )
- pyside2? (
- $(python_gen_cond_dep '
- dev-python/pyside2[${PYTHON_USEDEP}]
- dev-python/pyside2[designer?,gui?,help?,location?,multimedia?]
- dev-python/pyside2[network?,opengl(+)?,positioning?,printsupport?]
- dev-python/pyside2[sensors?,serialport(+)?,speech?,sql?,svg?]
- dev-python/pyside2[testlib?,webchannel?,webengine?,websockets?]
- dev-python/pyside2[widgets?,x11extras?,xml?,xmlpatterns?]
- declarative? ( dev-python/pyside2[qml,quick] )
- ' python3_{7..9} )
- )
-"
-
-# The QtPy testsuite skips tests for bindings that are not installed, so here we
-# ensure that everything is available and all tests are run. Note that not
-# all flags are available in PyQt5/PySide2, so some tests are still skipped.
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- pyqt5? (
- dev-python/PyQt5[${PYTHON_USEDEP}]
- dev-python/PyQt5[bluetooth,dbus,declarative,designer,gui,help,location]
- dev-python/PyQt5[multimedia,network,opengl,positioning,printsupport]
- dev-python/PyQt5[sensors,serialport,speech(-),sql,svg,testlib,webchannel]
- dev-python/PyQt5[websockets,widgets,x11extras,xml(+),xmlpatterns]
- dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
- )
- pyside2? (
- $(python_gen_cond_dep '
- dev-python/pyside2[${PYTHON_USEDEP}]
- dev-python/pyside2[3d,charts,concurrent,datavis,designer,gui,help]
- dev-python/pyside2[location,multimedia,network,opengl(+),positioning]
- dev-python/pyside2[printsupport,qml,quick,script,scripttools,scxml]
- dev-python/pyside2[sensors,serialport(+),speech,sql,svg,testlib]
- dev-python/pyside2[webchannel,webengine,websockets,widgets,x11extras]
- dev-python/pyside2[xml,xmlpatterns]
- ' python3_{7..9} )
- )
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- default
- # Disale Qt for Python implementations that are not selected
- if ! use pyqt5; then
- sed -i -e "s/from PyQt5.QtCore import/raise ImportError #/" qtpy/__init__.py || die
- fi
- if ! use pyside2; then
- sed -i -e "s/from PySide2 import/raise ImportError #/" qtpy/__init__.py || die
- sed -i -e "s/from PySide2.QtCore import/raise ImportError #/" qtpy/__init__.py || die
- fi
-
- # Disable outdated PyQt4 and PySide
- sed -i -e "s/from PyQt4.Qt import/raise ImportError #/" qtpy/__init__.py || die
- sed -i -e "s/from PyQt4.QtCore import/raise ImportError #/" qtpy/__init__.py || die
- sed -i -e "s/from PySide import/raise ImportError #/" qtpy/__init__.py || die
- sed -i -e "s/from PySide.QtCore import/raise ImportError #/" qtpy/__init__.py || die
-}
-
-src_test() {
- virtx python_foreach_impl python_test
-}
-
-python_test() {
- if use pyqt5; then
- QT_API="pyqt5" epytest
- fi
- if use pyside2; then
- if [[ "${EPYTHON}" == "python3.10" ]]; then
- return
- else
- QT_API="pyside2" epytest
- fi
- fi
-}
-
-pkg_postinst() {
- if use pyqt5 && use pyside2; then
- ewarn "You have enabled both PyQt5 and PySide2, note that QtPy will default"
- ewarn "to PyQt5 unless the QT_API environment variable overrides this."
- fi
-}