summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2017-01-03 13:28:33 -0600
committerWilliam Hubbs <williamh@gentoo.org>2017-01-05 18:08:01 -0600
commitaa0d59d0f79adf50a090ef3bbc17266c6dd9dc02 (patch)
treed01154c9be76f28ceabbab4a5c31b0d45cdddf17 /dev-python/ReParser/ReParser-1.4.3.ebuild
parentdev-python/readlike: initial ebuild (diff)
downloadgentoo-aa0d59d0f79adf50a090ef3bbc17266c6dd9dc02.tar.gz
gentoo-aa0d59d0f79adf50a090ef3bbc17266c6dd9dc02.tar.bz2
gentoo-aa0d59d0f79adf50a090ef3bbc17266c6dd9dc02.zip
dev-python/ReParser: initial ebuild
Package-Manager: Portage-2.3.0, Repoman-2.3.1
Diffstat (limited to 'dev-python/ReParser/ReParser-1.4.3.ebuild')
-rw-r--r--dev-python/ReParser/ReParser-1.4.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/ReParser/ReParser-1.4.3.ebuild b/dev-python/ReParser/ReParser-1.4.3.ebuild
new file mode 100644
index 000000000000..16cfd3fba821
--- /dev/null
+++ b/dev-python/ReParser/ReParser-1.4.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5} )
+inherit distutils-r1
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://github.com/hickford/MechanicalSoup"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="simple regex-based lexer/parser for inline markup"
+HOMEPAGE="https://pypi.python.org/pypi/ReParser"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""