summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gmail.com>2021-07-30 20:35:59 +0300
committerMichał Górny <mgorny@gentoo.org>2021-08-02 10:16:51 +0200
commit54629dcf903dce91562a4fcf19a2637d8422834c (patch)
treedbd49b9fff69fd0fe6bbffbfe9ebc6c4e478fa96 /dev-python/agate
parentdev-python/agate: enable doc generation (diff)
downloadgentoo-54629dcf903dce91562a4fcf19a2637d8422834c.tar.gz
gentoo-54629dcf903dce91562a4fcf19a2637d8422834c.tar.bz2
gentoo-54629dcf903dce91562a4fcf19a2637d8422834c.zip
dev-python/agate: drop 1.6.2-r1
Signed-off-by: Arthur Zamarin <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/agate')
-rw-r--r--dev-python/agate/Manifest1
-rw-r--r--dev-python/agate/agate-1.6.2-r1.ebuild71
2 files changed, 0 insertions, 72 deletions
diff --git a/dev-python/agate/Manifest b/dev-python/agate/Manifest
index 53a8e48bf651..72ba351ff55a 100644
--- a/dev-python/agate/Manifest
+++ b/dev-python/agate/Manifest
@@ -1,2 +1 @@
-DIST agate-1.6.2.tar.gz 191216 BLAKE2B 63e89f6815a36dea956e8a919aeb926291eaf1f4d5eaac7f96dab97c6958dfee4788e18a4c1325a5b8cebf15df27b32e75409ddeab1289c1e8e548088fdc0ea7 SHA512 34d9e45d162bce69d28ad0ec07f5b410b2cdac831e5bd986ca8cb8902fd0ca1ec67663b2f956f42acaf18b8ca0fa169d5236aa4cee7457765e4e86d837e7794e
DIST agate-1.6.3.tar.gz 202102 BLAKE2B b1a5624b4744b8f3ed266470da580cef2f2e1cf6159e1b33fcd461e4abd235c5e3fe0da35408a42c92fd4abf14a1f841a1ab9eb6cd31545d826a5223e85b4904 SHA512 e83a03c5a3e4b7fa9997030ce0d33e7b59b397e2ae07ee6a723eb7fb708a7fa8b8c4322dd034f42bf664bf2911d89731fd060e4ff33a237f83114a83312ac5ed
diff --git a/dev-python/agate/agate-1.6.2-r1.ebuild b/dev-python/agate/agate-1.6.2-r1.ebuild
deleted file mode 100644
index 7a908b2f5484..000000000000
--- a/dev-python/agate/agate-1.6.2-r1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{8..9} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
-
-inherit distutils-r1
-
-DESCRIPTION="A Python data analysis library that is optimized for humans instead of machines"
-HOMEPAGE="https://github.com/wireservice/agate https://pypi.org/project/agate/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test +xml"
-RESTRICT="!test? ( test )"
-
-# Other packages have BDEPEND="test? ( dev-python/agate[xml] )"
-LEATHER_VERSION_DEP=">=dev-python/leather-0.3.3-r2"
-TEST_AGAINST_RDEPEND="xml? ( ${LEATHER_VERSION_DEP}[xml,${PYTHON_USEDEP}] )"
-RDEPEND="
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- >=dev-python/pytimeparse-1.1.5[${PYTHON_USEDEP}]
- >=dev-python/parsedatetime-2.1[${PYTHON_USEDEP}]
- >=dev-python/Babel-2.0[${PYTHON_USEDEP}]
- >=dev-python/isodate-0.5.4[${PYTHON_USEDEP}]
- >=dev-python/pyicu-2.4.2[${PYTHON_USEDEP}]
- >=dev-python/python-slugify-1.2.1[${PYTHON_USEDEP}]
- ${LEATHER_VERSION_DEP}[${PYTHON_USEDEP}]
-
- ${TEST_AGAINST_RDEPEND}
-"
-BDEPEND="test? ( ${LEATHER_VERSION_DEP}[xml,${PYTHON_USEDEP}] )"
-
-distutils_enable_tests pytest
-
-# @FUNCTION: pytest-expect-to-deselect
-# @USAGE: readarray -t pytest_args < <(pytest-expect-to-deselect <<<PYTEST_EXPECT_CONTENT)
-# @DESCRIPTION:
-# Read a pytest-expect pytest --xfail-file file from stdin and write
-# equivalent pytest --deselect arguments to stdout for consumption by
-# readarray -t. The generated pytest --deselect arguments are appropriate
-# for use as described here:
-# https://dev.gentoo.org/~mgorny/python-guide/pytest.html#skipping-tests-based-on-paths-names
-pytest-expect-to-deselect() {
- while read -r; do
- [[ ${REPLY} =~ ^[u]?\'([^\']*) ]] || continue
- printf -- '%s\n' --deselect "${BASH_REMATCH[1]}" || return
- done
-}
-
-python_test() {
- # test_cast_format_locale fails with "locale.Error: unsupported locale setting"
- # which appears to be triggered by these locale settings in the unit tests:
- #
- # agate-1.6.2/tests/test_data_types.py:257: def test_cast_format_locale(self):
- # agate-1.6.2/tests/test_data_types.py-258- date_type = Date(date_format='%d-%b-%Y', locale='de_DE')
- # agate-1.6.2/tests/test_data_types.py:381: def test_cast_format_locale(self):
- # agate-1.6.2/tests/test_data_types.py-382- date_type = DateTime(datetime_format='%Y-%m-%d %I:%M %p', locale='ko_KR')
-
- local -a pytest_args
- readarray -t pytest_args < <(pytest-expect-to-deselect <<<"
-pytest-expect file v1
-(3, 8, 10, 'final', 0)
-u'tests/test_data_types.py::TestDate::test_cast_format_locale': FAIL
-u'tests/test_data_types.py::TestDateTime::test_cast_format_locale': FAIL
-")
-
- epytest "${pytest_args[@]}" || die
-}