summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2017-06-28 19:32:09 -0400
committerAaron Bauman <bman@gentoo.org>2017-07-09 20:16:38 -0400
commitb47d6bfadce218089f726137ae72c1b623291cba (patch)
tree8f32b0b2422739de266097692b601a671fe9ad99 /dev-python/aiohttp-cors
parentdev-python/aiohttp: add 1.3.5 for net-misc/gns3-server dependency (diff)
downloadgentoo-b47d6bfadce218089f726137ae72c1b623291cba.tar.gz
gentoo-b47d6bfadce218089f726137ae72c1b623291cba.tar.bz2
gentoo-b47d6bfadce218089f726137ae72c1b623291cba.zip
dev-python/aiohttp-cors: add 0.5.1 for net-misc/gns3-server dependency
Closes: https://github.com/gentoo/gentoo/pull/5007
Diffstat (limited to 'dev-python/aiohttp-cors')
-rw-r--r--dev-python/aiohttp-cors/Manifest1
-rw-r--r--dev-python/aiohttp-cors/aiohttp-cors-0.5.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/aiohttp-cors/Manifest b/dev-python/aiohttp-cors/Manifest
index 741ee1209ab6..dfdf4a6dff7d 100644
--- a/dev-python/aiohttp-cors/Manifest
+++ b/dev-python/aiohttp-cors/Manifest
@@ -1 +1,2 @@
DIST aiohttp-cors-0.5.0.tar.gz 40018 SHA256 7d0c682657db4f3265337875be75e5f222aef644e780e125267e98a690ff9d85 SHA512 86c24a1fe18fb3b2b8fca38ef9aa7ebf07fc1b202d353a540b7d651cbf618c57c5afbe125d91c0d72aee937909dbea0cfb1baa182eebdc5402b66f9800706bee WHIRLPOOL 0a73c3c737caced9222600a1ff22c58dcdb60624773d3947de3ea706a7725e1cf677c60254e860f67be336435be58477e620d45011f7d84a857420b20526717f
+DIST aiohttp-cors-0.5.1.tar.gz 40081 SHA256 207c29a5ba1270f42aea2d657db08b6049046cc3e5e7717fd2253d1189c4f916 SHA512 a06f65a479bbed50022394d51345e08bdf98a099f4b6efe355f4a4762155a564eee3d4e10ddb417daa7498ebc1abb93a3437b1a2cc6af9c2ad5fe8a8714c237c WHIRLPOOL 4d5a6669b16d601f190348880dcd718a1c1fd7a5812a3a78d05c88a62e1cc49518faf2aebf201b5da7e55758900db973d9c709bc6280b20127f70e142d8ea649
diff --git a/dev-python/aiohttp-cors/aiohttp-cors-0.5.1.ebuild b/dev-python/aiohttp-cors/aiohttp-cors-0.5.1.ebuild
new file mode 100644
index 000000000000..f0c5fa8cee4e
--- /dev/null
+++ b/dev-python/aiohttp-cors/aiohttp-cors-0.5.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_4 python3_5 python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements CORS support for aiohttp asyncio-powered asynchronous HTTP server"
+HOMEPAGE="https://github.com/aio-libs/aiohttp-cors"
+SRC_URI="https://github.com/aio-libs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+EGIT_REPO_URI="https://github.com/aio-libs/aiohttp-cors"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND=">=dev-python/aiohttp-1.1.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/typing[${PYTHON_USEDEP}]' python3_4)"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-pylint[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/selenium[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # for some reason, it is installed by 'setup.py test' on py!=3.4
+ # TODO: investigate
+ sed -i -e '/typing/d' setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}