summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-01-27 16:05:16 +0100
committerPacho Ramos <pacho@gentoo.org>2019-01-27 16:05:16 +0100
commite9b2ee522e690cab109e071db5d744f6bec5bce1 (patch)
treec8243934e9ea02f44db822ca52bd45e78a689623 /dev-python/aiohttp-cors
parentdev-db/phpmyadmin: Drop old vulnerable releases. (diff)
downloadgentoo-e9b2ee522e690cab109e071db5d744f6bec5bce1.tar.gz
gentoo-e9b2ee522e690cab109e071db5d744f6bec5bce1.tar.bz2
gentoo-e9b2ee522e690cab109e071db5d744f6bec5bce1.zip
dev-python/aiohttp-cors: One 0.5 version needed for gns3-server
Package-Manager: Portage-2.3.58, Repoman-2.3.12 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-python/aiohttp-cors')
-rw-r--r--dev-python/aiohttp-cors/Manifest1
-rw-r--r--dev-python/aiohttp-cors/aiohttp-cors-0.5.3.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/aiohttp-cors/Manifest b/dev-python/aiohttp-cors/Manifest
index 0befccb4462b..ff5076ab3fd5 100644
--- a/dev-python/aiohttp-cors/Manifest
+++ b/dev-python/aiohttp-cors/Manifest
@@ -1 +1,2 @@
+DIST aiohttp-cors-0.5.3.tar.gz 40266 BLAKE2B 701886b291a1b89f88a704ae04e3264cf2afc51f63f03ddd4464d40ba7bd3a1c6b5fe3f095b634e8c6c36c5a967e9a6b9b88335ff23988fc8bcd726c037fbd1c SHA512 0813ea48de714c85e361dfdaeef1a69526f7446dcc4ce637139cd333dedea58c635f85cfad1c3ccfb0df6e573f0351f282fdbd9726211d5915ed2ba120206b09
DIST aiohttp-cors-0.6.0.tar.gz 42507 BLAKE2B 7b63916b983d3dc208058c8b04445a30762eebc4999135ae802d1ceeeccc476a335eae66126bb3fd16f938af3649e8b9096433c2df09e82bf4e5d4ba8e38c42c SHA512 75453ebbc074d5f25cc8efc46ffdb76fc90b0a96a9e6fce0eee5a5f28dba31cb50301289cac3b36c70ccdbc10c8f4ba9e362d8e9f350ba7f9dfacd06e6f5e699
diff --git a/dev-python/aiohttp-cors/aiohttp-cors-0.5.3.ebuild b/dev-python/aiohttp-cors/aiohttp-cors-0.5.3.ebuild
new file mode 100644
index 000000000000..5448c38b7cd9
--- /dev/null
+++ b/dev-python/aiohttp-cors/aiohttp-cors-0.5.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_4 python3_5 python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements CORS support for aiohttp asyncio-powered asynchronous HTTP server"
+HOMEPAGE="https://github.com/aio-libs/aiohttp-cors"
+SRC_URI="https://github.com/aio-libs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+EGIT_REPO_URI="https://github.com/aio-libs/aiohttp-cors"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/aiohttp-1.1.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/typing[${PYTHON_USEDEP}]' python3_4)"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-pylint[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/selenium[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # for some reason, it is installed by 'setup.py test' on py!=3.4
+ # TODO: investigate
+ sed -i -e '/typing/d' setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}