summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2017-01-29 20:06:59 +0900
committerAaron Bauman <bman@gentoo.org>2017-01-29 20:16:38 +0900
commitf85cda0c70fd51660ca8d8fc165fe358de27472c (patch)
tree350a1d686e64544cf7480bdbc2a2321af2b24d23 /dev-python/aiohttp-cors
parentx11-misc/parcellite: Version bump (bug 607550, thanks Arnaud Vallette d'Osia). (diff)
downloadgentoo-f85cda0c70fd51660ca8d8fc165fe358de27472c.tar.gz
gentoo-f85cda0c70fd51660ca8d8fc165fe358de27472c.tar.bz2
gentoo-f85cda0c70fd51660ca8d8fc165fe358de27472c.zip
dev-python/aiohttp-cors: new package needed by net-misc/gns3-server
Diffstat (limited to 'dev-python/aiohttp-cors')
-rw-r--r--dev-python/aiohttp-cors/Manifest3
-rw-r--r--dev-python/aiohttp-cors/aiohttp-cors-0.5.0.ebuild23
-rw-r--r--dev-python/aiohttp-cors/metadata.xml11
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/aiohttp-cors/Manifest b/dev-python/aiohttp-cors/Manifest
new file mode 100644
index 000000000000..14eeb5a44ada
--- /dev/null
+++ b/dev-python/aiohttp-cors/Manifest
@@ -0,0 +1,3 @@
+DIST aiohttp-cors-0.5.0.tar.gz 40018 SHA256 7d0c682657db4f3265337875be75e5f222aef644e780e125267e98a690ff9d85 SHA512 86c24a1fe18fb3b2b8fca38ef9aa7ebf07fc1b202d353a540b7d651cbf618c57c5afbe125d91c0d72aee937909dbea0cfb1baa182eebdc5402b66f9800706bee WHIRLPOOL 0a73c3c737caced9222600a1ff22c58dcdb60624773d3947de3ea706a7725e1cf677c60254e860f67be336435be58477e620d45011f7d84a857420b20526717f
+EBUILD aiohttp-cors-0.5.0.ebuild 652 SHA256 265217cae868cd01c7be7c5c427f8f3395317abe74878b392a7be74c593ed71a SHA512 170db103594fdb243c72c7cb24320686674de9e3a06eba79ebecaf8f91ccd1438cbdc0e91b12e2cc46bcacf6e13e9589873c3c950875acd00bf5e5f00212f256 WHIRLPOOL 9623cc87cba7124d88b05d01d57d22e646f2b3b45d7b77708d8ffd82f0952ba66251c19a6f6f5572eb99051eca07c8efccdb61a8942e9437b688990ec177f99b
+MISC metadata.xml 329 SHA256 b4138094c6a8614ee818ee282633a535e79c4cb1f7270199afa467fa903fcada SHA512 11dfa0999b7a54c6db3c0242297cc491e3890469b8549cd858b110cb65868b1431ee5487033d48522daaab81dab7b113249cd4223d4597bee8043bf98496e71c WHIRLPOOL a73ae58b83e8ac31a0355a6cd6fa1c806f82547b4deab419857c268328c75c99a8421b0819720bfac32384815efedc1d5bb58927e3e1085419ea3560e7231e5b
diff --git a/dev-python/aiohttp-cors/aiohttp-cors-0.5.0.ebuild b/dev-python/aiohttp-cors/aiohttp-cors-0.5.0.ebuild
new file mode 100644
index 000000000000..ce58bea79fdf
--- /dev/null
+++ b/dev-python/aiohttp-cors/aiohttp-cors-0.5.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements CORS support for aiohttp asyncio-powered asynchronous HTTP server"
+HOMEPAGE="https://github.com/aio-libs/aiohttp-cors"
+SRC_URI="https://github.com/aio-libs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+EGIT_REPO_URI="https://github.com/aio-libs/aiohttp-cors"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test"
+
+DEPEND=">=dev-python/aiohttp-1.1.1[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/aiohttp-cors/metadata.xml b/dev-python/aiohttp-cors/metadata.xml
new file mode 100644
index 000000000000..c89d18d815c9
--- /dev/null
+++ b/dev-python/aiohttp-cors/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bman@gentoo.org</email>
+ <name>Aaron Bauman</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">aio-libs/aiohttp-cors</remote-id>
+ </upstream>
+</pkgmetadata>