summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-01 11:55:48 +0000
committerSam James <sam@gentoo.org>2021-06-01 11:55:57 +0000
commit3e9b9129d55821984c71ff2f29a75f9891e19027 (patch)
tree6dd7b855a28c1b5cd748de594f9bd790a2630eef /dev-python/aiohttp-jinja2
parentdev-python/pygame_sdl2: add Python 3.9 (diff)
downloadgentoo-3e9b9129d55821984c71ff2f29a75f9891e19027.tar.gz
gentoo-3e9b9129d55821984c71ff2f29a75f9891e19027.tar.bz2
gentoo-3e9b9129d55821984c71ff2f29a75f9891e19027.zip
dev-python/aiohttp-jinja2: add 1.4.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/aiohttp-jinja2')
-rw-r--r--dev-python/aiohttp-jinja2/Manifest1
-rw-r--r--dev-python/aiohttp-jinja2/aiohttp-jinja2-1.4.2.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/aiohttp-jinja2/Manifest b/dev-python/aiohttp-jinja2/Manifest
index 28e0da6d8007..c40dead9fd2c 100644
--- a/dev-python/aiohttp-jinja2/Manifest
+++ b/dev-python/aiohttp-jinja2/Manifest
@@ -1 +1,2 @@
DIST aiohttp-jinja2-0.15.0.tar.gz 51183 BLAKE2B e19ca813f36ac746a84812ec278a3de43e6e24eaafcf949fd18a32c99f460ded03f4dc97171fe1493174a8e2c51543b8c1afcdec51c4688f4fb0b7781287cc03 SHA512 084714cd2376b93f32cdcebc1971d4aaa704a177524b00f322e0347c15ab8085960a68a3760be056e391410f01b6b637eb59db54fccf54d09ba53a9ea03a01db
+DIST aiohttp-jinja2-1.4.2.tar.gz 54328 BLAKE2B 3d6aaeb03bbb89516a92fa877ee95a2fd27ab83666a03ca12e78f1744b82797faf2547bf55118618cbd979d80779a9571dfcfe9036bc84142563ede55cfbc1a1 SHA512 7bdaee97efe90a0009cd78a4e46dc80cfeb661c2d5561fdb1b1a1ff098abba8667260bb908e3227edd6601c2412812d0311461942568a8aabf07a164ea2f290e
diff --git a/dev-python/aiohttp-jinja2/aiohttp-jinja2-1.4.2.ebuild b/dev-python/aiohttp-jinja2/aiohttp-jinja2-1.4.2.ebuild
new file mode 100644
index 000000000000..47be01d04239
--- /dev/null
+++ b/dev-python/aiohttp-jinja2/aiohttp-jinja2-1.4.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="jinja2 template renderer for aiohttp.web"
+HOMEPAGE="https://github.com/aio-libs/aiohttp-jinja2"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/aiohttp-2.3.9[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ doc? (
+ >=dev-python/alabaster-0.6.2[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? ( >=dev-python/pytest-aiohttp-0.3.0[${PYTHON_USEDEP}] )
+"
+
+DOCS=( README.rst )
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's:--cov=aiohttp_jinja2 --cov-report xml --cov-report html --cov-report term::' \
+ setup.cfg || die
+
+ distutils-r1_src_prepare
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}