summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-27 00:43:43 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-27 00:48:37 +0100
commit52be562e11d0b8ca03c408db680cb55fee6b904d (patch)
tree8a6d2876632fac7a7ac2c7ec16b8c6b298b14d4b /dev-python/aiohttp
parentdev-python/aiohttp: Fix deps, tests and modernize (diff)
downloadgentoo-52be562e11d0b8ca03c408db680cb55fee6b904d.tar.gz
gentoo-52be562e11d0b8ca03c408db680cb55fee6b904d.tar.bz2
gentoo-52be562e11d0b8ca03c408db680cb55fee6b904d.zip
dev-python/aiohttp: Bump to 3.7.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiohttp')
-rw-r--r--dev-python/aiohttp/Manifest1
-rw-r--r--dev-python/aiohttp/aiohttp-3.7.3.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/dev-python/aiohttp/Manifest b/dev-python/aiohttp/Manifest
index 9612d2abc7e8..8421df782f14 100644
--- a/dev-python/aiohttp/Manifest
+++ b/dev-python/aiohttp/Manifest
@@ -1,3 +1,4 @@
DIST aiohttp-3.6.2.tar.gz 1076923 BLAKE2B 14327a0bc5b5fffdf436a4c3525e4c25d80100aa464ed652316f7724c2bea6de4ace6c27e8a2a8cf9d895673ed63ed52e8c958ad611636e1e524a4e40efa4735 SHA512 49bd3089158c05ff6312420190ccd7fed95efb4a18b8aff7497d5507c71c692080d6949801edabdcd95379ca8e6614398408118d72ff1e782399e059e2cfc1a8
DIST aiohttp-3.7.1.tar.gz 1111777 BLAKE2B 03d16e8c9d64ec407cf7b6dbbf5547a88f528ab23e9e256559c11fc2cb6f568101f79dad89b0e5698fd02a3918051e4bc3c349e3ea4358ecb5de1543fea91708 SHA512 accdd588fdd7ba1792cf5e8fb67c6d5dd3e1c5382d9c9ece14e449d6f4f1c116975809d2dad786e0d472b3bb54e3b8c59722be871401a82cef5eff9c12f3c3f8
DIST aiohttp-3.7.2.tar.gz 1111049 BLAKE2B faffc582f2c72ff892862b5b782da75b381e59b21b284b1120e4edb16f22b760f8cabe56261061e0049a5dfd041456076e294e942a02309e9b3d6b414facb0cb SHA512 2dd4f0264f1fb0801be366c269b73dd80b542e8e5bfe18a01fbdfadd0210022ccd6e3975be1be416551ccce82f42881e18735d5c6fc68a42b7452ab18e157dc5
+DIST aiohttp-3.7.3.tar.gz 1113127 BLAKE2B 47d95565db1184c6b55a1e7d7a6df8cda872e4fe621f653e3143608f51dde2c7d30d00835da357dd7ae33f4858ad5778074dfde5261331a3539a5d6776ea1a25 SHA512 d1dbbe3cbdeb1a460f5030a08a251a7bb7ae7ec038ca93ba5187b2da1fe21b80ed6513db647ef382d2d92a3d527a34dffbd37f51aa1e8b65bb36d517304b1812
diff --git a/dev-python/aiohttp/aiohttp-3.7.3.ebuild b/dev-python/aiohttp/aiohttp-3.7.3.ebuild
new file mode 100644
index 000000000000..9e8be6e734f4
--- /dev/null
+++ b/dev-python/aiohttp/aiohttp-3.7.3.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="http client/server for asyncio"
+HOMEPAGE="https://pypi.org/project/aiohttp/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/async_timeout-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/attrs-17.3.0[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ >=dev-python/multidict-4.5.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/idna-ssl[${PYTHON_USEDEP}]
+ ' python3_6)
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ !!dev-python/pytest-aiohttp
+ dev-python/async_generator[${PYTHON_USEDEP}]
+ dev-python/brotlipy[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ www-servers/gunicorn[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/re-assert[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( CHANGES.rst CONTRIBUTORS.txt README.rst )
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ '>=dev-python/alabaster-0.6.2' \
+ 'dev-python/sphinxcontrib-asyncio' \
+ 'dev-python/sphinxcontrib-blockdiag' \
+ 'dev-python/sphinxcontrib-newsfeed' \
+ 'dev-python/sphinxcontrib-spelling' \
+ 'dev-python/sphinx' \
+ 'dev-python/sphinx-aiohttp-theme'
+
+python_prepare_all() {
+ # Fails due to a warning
+ sed -e 's:test_read_boundary_with_incomplete_chunk:_&:' \
+ -i tests/test_multipart.py || die
+ # with py3.7+
+ sed -e 's:test_aiohttp_request_coroutine:_&:' \
+ -i tests/test_client_functional.py || die
+
+ # Fails due to path mismatch
+ sed -e 's:test_static:_&:' \
+ -i tests/test_route_def.py || die
+
+ # Internet
+ sed -e 's:test_mark_formdata_as_processed:_&:' \
+ -i tests/test_formdata.py || die
+
+ # takes a very long time, then fails
+ rm tests/test_pytest_plugin.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ pushd "${BUILD_DIR}/lib" >/dev/null || die
+ ln -snf "${S}"/{LICENSE.txt,tests} . || die
+ pytest -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" --forked \
+ -vv tests || die "Tests fail with ${EPYTHON}"
+ rm -rf .pytest_cache tests || die
+ popd >/dev/null || die
+}