summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-04-20 14:05:36 -0700
committerZac Medico <zmedico@gentoo.org>2017-04-20 14:08:23 -0700
commit594200e167d0ae2311964edb64963a578a305bb4 (patch)
tree57c8ea01c427059da0ee08df83f52f0ce117ae02 /dev-python/aiohttp
parentdev-util/yacc: quote variables correctly. (diff)
downloadgentoo-594200e167d0ae2311964edb64963a578a305bb4.tar.gz
gentoo-594200e167d0ae2311964edb64963a578a305bb4.tar.bz2
gentoo-594200e167d0ae2311964edb64963a578a305bb4.zip
dev-python/aiohttp: version bump to 1.3.5
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/aiohttp')
-rw-r--r--dev-python/aiohttp/Manifest1
-rw-r--r--dev-python/aiohttp/aiohttp-1.3.5.ebuild68
-rw-r--r--dev-python/aiohttp/metadata.xml2
3 files changed, 70 insertions, 1 deletions
diff --git a/dev-python/aiohttp/Manifest b/dev-python/aiohttp/Manifest
index 3ef75bd63b48..731d4a7093f5 100644
--- a/dev-python/aiohttp/Manifest
+++ b/dev-python/aiohttp/Manifest
@@ -6,3 +6,4 @@ DIST aiohttp-1.1.1.tar.gz 575872 SHA256 6f624d2b340a2c622949e5585540373a86349d31
DIST aiohttp-1.1.2.tar.gz 576160 SHA256 8be33ad39522d5fbc06ce527da4615bf93e6c5d4f933173072bc51fa27ea0cf4 SHA512 ccba7a8e9a2cebaa0afadcfa927fbe9113577b2c69165cd64d8f1169d6cdb4efca252a228ad8d4780b20fcc94fffb9fa8217cbd0d49cbe9c5560a81e4423be41 WHIRLPOOL ea3f9d74f7c4a0d266b56a2cd5a8655734fd8c9043a7b8f5423f960ff90cbaec1b1d6f3965b089d1cb4db7e1abb39a58dd7d5f627e6f88fb292c822ae75ab77a
DIST aiohttp-1.1.5.tar.gz 577346 SHA256 8f4c31a10b0a96667ac8a13e3756a3505e040c423c3c4075b99745056b3537d8 SHA512 44b1474a64ce150164045f30734da119a1848a3677d885493f99f2d724d20884dac9a24adce4b90017e203fc67b295443f91d14f1af9eb20d657a3cd4b69d747 WHIRLPOOL 036265681123f902aaa2000fd6ddd83980c3b1a48d67b583b5e1da7e7079d381a9c92669c12040c1494ba3890c2a849cd1f190003a1ec611df7a72843242bcec
DIST aiohttp-1.2.0.tar.gz 589818 SHA256 b2fa11df067207ff15813be84b78910f6f9d897f02e9c345993b9962802a6bea SHA512 4101f0aad0d6bb8caf931dbd7f9e07bfdaa445796af92c84ea999538c2767f3cd62740ea9c7e07f255eb57b52e967e5343461809a5d5f4e8b12cd4383753bd77 WHIRLPOOL 239f802ce1dde24b3e1c6fba39357822564256f1aae167b44164d9bab3e67113400534df0835ca6b5245b8229dcab752149774c7adde1e1aef2a0f549d2d33ad
+DIST aiohttp-1.3.5.tar.gz 527432 SHA256 cd14a45da385b5e860849ffaff3ecee56f9b37bf9e7f3f7bc5ce3f17556cf842 SHA512 b99630fa9006163d61e0e010972aee8daad021c5ad0152b04fb6f8b661f18ea03fcfa8d35603ecfcdaef4ecbaff0159b49e2f40164241bb5def48b2847e2d966 WHIRLPOOL b39e5a5081cadb497aa982b8bee1a24615a2e382071755586c52855529c7984c9140c04239fe9ef81e51f3e11a1ea7b1c021f6b8a4dd58c4d826f934394b5576
diff --git a/dev-python/aiohttp/aiohttp-1.3.5.ebuild b/dev-python/aiohttp/aiohttp-1.3.5.ebuild
new file mode 100644
index 000000000000..0070d6eeb7f3
--- /dev/null
+++ b/dev-python/aiohttp/aiohttp-1.3.5.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="http client/server for asyncio"
+HOMEPAGE="https://pypi.python.org/pypi/aiohttp"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
+EGIT_REPO_URI="https://github.com/aio-libs/aiohttp"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+CDEPEND="
+ dev-python/async_timeout[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ >=dev-python/multidict-2.1.4[${PYTHON_USEDEP}]
+ >=dev-python/yarl-0.9.8[${PYTHON_USEDEP}]
+ <dev-python/yarl-0.10[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/alabaster-0.6.2[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-asyncio[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-newsfeed[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-spelling[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${CDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ www-servers/gunicorn[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -e 's|^ self.pid = '\''pid'\'$'|\
+ try:\
+ self.pid = '\''pid'\''\
+ except:\
+ pass|' -i tests/test_worker.py || die
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="${PWD}:${PYTHONPATH}" ${PYTHON} -m pytest tests/ || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/aiohttp/metadata.xml b/dev-python/aiohttp/metadata.xml
index d86e5838f4d4..e5671a7088b1 100644
--- a/dev-python/aiohttp/metadata.xml
+++ b/dev-python/aiohttp/metadata.xml
@@ -7,6 +7,6 @@
</maintainer>
<upstream>
<remote-id type="pypi">aiohttp</remote-id>
- <remote-id type="github">KeepSafe/aiohttp</remote-id>
+ <remote-id type="github">aio-libs/aiohttp</remote-id>
</upstream>
</pkgmetadata>