summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-29 09:26:55 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-29 10:00:10 +0100
commita04af5412967e7fca8b23631dda3c5d37d69b7b8 (patch)
treea496bce1a25dcc5ea93147159048d12599953a09 /dev-python/aiosmtpd
parentx11-libs/libva: Use upstream fix for USE="wayland" build (diff)
downloadgentoo-a04af5412967e7fca8b23631dda3c5d37d69b7b8.tar.gz
gentoo-a04af5412967e7fca8b23631dda3c5d37d69b7b8.tar.bz2
gentoo-a04af5412967e7fca8b23631dda3c5d37d69b7b8.zip
dev-python/aiosmtpd: Bump to 1.2.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiosmtpd')
-rw-r--r--dev-python/aiosmtpd/Manifest1
-rw-r--r--dev-python/aiosmtpd/aiosmtpd-1.2.4.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/aiosmtpd/Manifest b/dev-python/aiosmtpd/Manifest
index bb4465d92f1f..8b556c8d1d92 100644
--- a/dev-python/aiosmtpd/Manifest
+++ b/dev-python/aiosmtpd/Manifest
@@ -1,2 +1,3 @@
DIST aiosmtpd-1.2.2.tar.gz 170459 BLAKE2B abf178c28a21c25e8a7c7ed920c154f037aaa21da5d2dfa0ee8cae7d239d00d5a979eedfb3865e3de7e54e7da94ea8a1e6b5194681a2137ac7d8f0f69d82e3a6 SHA512 7ffc279a73685601496dbfffef30a78cc254a76f8c8fccd0c7b7efe41da66672f0d8662f302eb928e90eb8977b859cb7e713415d0aa5e93f369ef23bdff405fc
+DIST aiosmtpd-1.2.4.tar.gz 83329 BLAKE2B accecbc3fe66efc748d0bc3c85504d731005b907435fada5b3c7ae0f7778e89f19d7c15a7edb194a7ba6310a450132728557a441b3fb2958d3658b0a15d3ccf5 SHA512 dc6041e284daceb89f8ca83b5cd715a5811eb4cf76504c23112e24c97d6c88480667c713ce094c2dcbc5b12a80605e551b6aadc4b1ce499089be68c7c4e7df8c
DIST aiosmtpd-1.2.tar.gz 51457 BLAKE2B c2dba38c5d5a243a65c332cb3b6bf85a124eb6ab9c3526d0ef57788eb7e24e64ec86c56eeaa57e5171631c8a965447f125366741b1d1c54fb48473da5123ed40 SHA512 520b0fae80423d3963d4f17ef393cc0ce9e342fd1237c909159706bfe1e13f27df849fbc14aa1c94ad02e7c9108308984b6f9e21c7dbddb09093ef00884983d8
diff --git a/dev-python/aiosmtpd/aiosmtpd-1.2.4.ebuild b/dev-python/aiosmtpd/aiosmtpd-1.2.4.ebuild
new file mode 100644
index 000000000000..b1e3efbb9abf
--- /dev/null
+++ b/dev-python/aiosmtpd/aiosmtpd-1.2.4.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="asyncio based SMTP server"
+HOMEPAGE="https://aiosmtpd.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/atpublic[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest