summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2020-09-03 09:48:58 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-09-03 09:50:37 -0700
commit4e2b946ee8b432fc60befcec48b9dbbe03f3ce4e (patch)
tree3b8728f930abd90bf7f907545389ddf82949b654 /dev-python/alagitpull
parentros-meta/geometry2: Bump to 0.7.5. (diff)
downloadgentoo-4e2b946ee8b432fc60befcec48b9dbbe03f3ce4e.tar.gz
gentoo-4e2b946ee8b432fc60befcec48b9dbbe03f3ce4e.tar.bz2
gentoo-4e2b946ee8b432fc60befcec48b9dbbe03f3ce4e.zip
dev-python/alagitpull-0.0.23-r1: Revbump, fix deps, add py38, py39
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/alagitpull')
-rw-r--r--dev-python/alagitpull/alagitpull-0.0.23-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/alagitpull/alagitpull-0.0.23-r1.ebuild b/dev-python/alagitpull/alagitpull-0.0.23-r1.ebuild
new file mode 100644
index 000000000000..cae488ea6060
--- /dev/null
+++ b/dev-python/alagitpull/alagitpull-0.0.23-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="alabaster sub-theme used on git-pull docs"
+HOMEPAGE="https://github.com/git-pull/alagitpull"
+SRC_URI="https://github.com/git-pull/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+SLOT="0"
+
+RDEPEND="
+ <dev-python/alabaster-0.8[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}"
+
+# no tests...