summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-02-26 20:32:57 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-02-26 20:32:57 -0600
commit820d77ccba73149a963d54a58c6bee2e62bd7c8e (patch)
tree3600162ddce12b26bf4d824a76743a708e3e2735 /dev-python/alembic/alembic-0.8.10.ebuild
parentdev-python/python-sqlparse: bup (diff)
downloadgentoo-820d77ccba73149a963d54a58c6bee2e62bd7c8e.tar.gz
gentoo-820d77ccba73149a963d54a58c6bee2e62bd7c8e.tar.bz2
gentoo-820d77ccba73149a963d54a58c6bee2e62bd7c8e.zip
dev-python/alembic: bup
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/alembic/alembic-0.8.10.ebuild')
-rw-r--r--dev-python/alembic/alembic-0.8.10.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/alembic/alembic-0.8.10.ebuild b/dev-python/alembic/alembic-0.8.10.ebuild
new file mode 100644
index 000000000000..9407498fc640
--- /dev/null
+++ b/dev-python/alembic/alembic-0.8.10.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5)
+
+inherit distutils-r1
+
+DESCRIPTION="database migrations tool, written by the author of SQLAlchemy"
+HOMEPAGE="https://bitbucket.org/zzzeek/alembic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test doc"
+
+# requires.txt cites 'SQLAlchemy>=0.7.3' which is really both old and silly
+# because it shatters the testsuite. If 'someone' cares to adhere to correct form
+# and edit to -0.7.3, feel free, and then pick up the pieces.
+RDEPEND=">=dev-python/sqlalchemy-0.8.4[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/python-editor-0.3[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+# For test phase
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # suite passes all if run from source. The residual fail & error are quite erroneous
+ rm tests/test_script_consumption.py
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ${EPYTHON} run_tests.py || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+
+ distutils-r1_python_install_all
+}