summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-10-11 14:13:00 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-16 20:20:55 +0200
commitafe50311737e691aa3397e0e0f6b91838d608dea (patch)
tree1cf6e75c468f000540ea6f415ac8ca47e87dbf33 /dev-python/alembic
parentdev-python/unittest2: correct DISTUTILS_USE_SETUPTOOLS (diff)
downloadgentoo-afe50311737e691aa3397e0e0f6b91838d608dea.tar.gz
gentoo-afe50311737e691aa3397e0e0f6b91838d608dea.tar.bz2
gentoo-afe50311737e691aa3397e0e0f6b91838d608dea.zip
dev-python/alembic: correct DISTUTILS_USE_SETUPTOOLS
Closes: https://bugs.gentoo.org/745654 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/alembic')
-rw-r--r--dev-python/alembic/alembic-1.4.2.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-python/alembic/alembic-1.4.2.ebuild b/dev-python/alembic/alembic-1.4.2.ebuild
index e014e8a05278..41d1166ea31f 100644
--- a/dev-python/alembic/alembic-1.4.2.ebuild
+++ b/dev-python/alembic/alembic-1.4.2.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
@@ -20,7 +21,7 @@ RDEPEND=">=dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
dev-python/mako[${PYTHON_USEDEP}]
>=dev-python/python-editor-0.3[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+DEPEND="
test? ( ${RDEPEND}
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]