summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-09-21 18:25:25 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-09-21 18:25:41 -0500
commite94ba47f475fb4a991689a818d6095734f3edbcb (patch)
tree7b4c8d3c14c30bcf070fee2bce31c7a474a35c83 /dev-python/alembic
parentdev-python/graph-tool: Remove old 2.29 (diff)
downloadgentoo-e94ba47f475fb4a991689a818d6095734f3edbcb.tar.gz
gentoo-e94ba47f475fb4a991689a818d6095734f3edbcb.tar.bz2
gentoo-e94ba47f475fb4a991689a818d6095734f3edbcb.zip
dev-python/alembic: 1.4.2 fix tests
Closes: https://bugs.gentoo.org/743151 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/alembic')
-rw-r--r--dev-python/alembic/alembic-1.4.2.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-python/alembic/alembic-1.4.2.ebuild b/dev-python/alembic/alembic-1.4.2.ebuild
index 581f85706873..e014e8a05278 100644
--- a/dev-python/alembic/alembic-1.4.2.ebuild
+++ b/dev-python/alembic/alembic-1.4.2.ebuild
@@ -22,6 +22,7 @@ RDEPEND=">=dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}] )"
# For test phase
@@ -35,7 +36,7 @@ python_prepare_all() {
}
python_test() {
- ${EPYTHON} run_tests.py || die "Testing failed with ${EPYTHON}"
+ ${EPYTHON} -m pytest --dropfirst || die "Testing failed with ${EPYTHON}"
}
python_install_all() {