summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-20 14:46:32 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-20 14:46:32 +0200
commit8fb6a431b3537745847b030f92ff18cc7e314555 (patch)
tree0d79cb3433bc20d7d1fb1b3c0fe4b26074f9f924 /dev-python/algopy/algopy-0.5.3.ebuild
parentdev-python/eventlet: Unset PYTHONPATH to fix tests (diff)
downloadgentoo-8fb6a431b3537745847b030f92ff18cc7e314555.tar.gz
gentoo-8fb6a431b3537745847b030f92ff18cc7e314555.tar.bz2
gentoo-8fb6a431b3537745847b030f92ff18cc7e314555.zip
dev-python/algopy: Remove last-rited pkg
Closes: https://bugs.gentoo.org/730760 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/algopy/algopy-0.5.3.ebuild')
-rw-r--r--dev-python/algopy/algopy-0.5.3.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/algopy/algopy-0.5.3.ebuild b/dev-python/algopy/algopy-0.5.3.ebuild
deleted file mode 100644
index 4deca4ef6ad9..000000000000
--- a/dev-python/algopy/algopy-0.5.3.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Taylor Arithmetic Computation and Algorithmic Differentiation"
-HOMEPAGE="https://pypi.org/project/algopy/ https://pythonhosted.org/algopy/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- || (
- dev-python/numpy-python2[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- )
- || (
- sci-libs/scipy-python2[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]
- )
-"
-DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
-PATCHES=( "${FILESDIR}/${P}-fix-test-cast-ufunc.patch" )
-
-python_test() {
- ${EPYTHON} run_tests.py || die
-}