summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-03 21:37:52 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-03 21:45:57 +0100
commit617c1b8f02d9a2f1dcd5b053f78a74d144595fb5 (patch)
tree4fec4f3bc22f157431fe1fa10124b68a93b193e1 /dev-python/aniso8601
parentdev-python/flask-restful: Remove py2 (diff)
downloadgentoo-617c1b8f02d9a2f1dcd5b053f78a74d144595fb5.tar.gz
gentoo-617c1b8f02d9a2f1dcd5b053f78a74d144595fb5.tar.bz2
gentoo-617c1b8f02d9a2f1dcd5b053f78a74d144595fb5.zip
dev-python/aniso8601: Remove py2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aniso8601')
-rw-r--r--dev-python/aniso8601/aniso8601-1.3.0.ebuild2
-rw-r--r--dev-python/aniso8601/aniso8601-3.0.0.ebuild2
-rw-r--r--dev-python/aniso8601/aniso8601-3.0.2.ebuild2
-rw-r--r--dev-python/aniso8601/aniso8601-4.0.1.ebuild5
4 files changed, 5 insertions, 6 deletions
diff --git a/dev-python/aniso8601/aniso8601-1.3.0.ebuild b/dev-python/aniso8601/aniso8601-1.3.0.ebuild
index b7ddea2ddc0f..5f5df95319d6 100644
--- a/dev-python/aniso8601/aniso8601-1.3.0.ebuild
+++ b/dev-python/aniso8601/aniso8601-1.3.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
+PYTHON_COMPAT=( python3_6 pypy3 )
inherit distutils-r1
diff --git a/dev-python/aniso8601/aniso8601-3.0.0.ebuild b/dev-python/aniso8601/aniso8601-3.0.0.ebuild
index a04ddfef77f4..fd6f9abd9f27 100644
--- a/dev-python/aniso8601/aniso8601-3.0.0.ebuild
+++ b/dev-python/aniso8601/aniso8601-3.0.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
+PYTHON_COMPAT=( python3_6 pypy3 )
inherit distutils-r1
diff --git a/dev-python/aniso8601/aniso8601-3.0.2.ebuild b/dev-python/aniso8601/aniso8601-3.0.2.ebuild
index 35c08d46190f..bb7a27ade76e 100644
--- a/dev-python/aniso8601/aniso8601-3.0.2.ebuild
+++ b/dev-python/aniso8601/aniso8601-3.0.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
+PYTHON_COMPAT=( python3_6 pypy3 )
inherit distutils-r1
diff --git a/dev-python/aniso8601/aniso8601-4.0.1.ebuild b/dev-python/aniso8601/aniso8601-4.0.1.ebuild
index bfa2cb8ec8c9..3251321fa7ca 100644
--- a/dev-python/aniso8601/aniso8601-4.0.1.ebuild
+++ b/dev-python/aniso8601/aniso8601-4.0.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
+PYTHON_COMPAT=( python3_{6,7} pypy3 )
inherit distutils-r1
@@ -17,8 +17,7 @@ IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND=">=dev-python/python-dateutil-2.7.3[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
PATCHES=( "${FILESDIR}"/${P}-mock.patch )