summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-09-12 01:40:00 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-09-17 00:31:11 +0200
commit77207d3d80b075208e9dd6b001d63d39a4ede9db (patch)
tree79393ecade84152525b8086263b6f014a4998512 /dev-python/ansi2html
parentdev-python/pypy3: Bump PyPy3.7 to 7.3.2_rc2 (diff)
downloadgentoo-77207d3d80b075208e9dd6b001d63d39a4ede9db.tar.gz
gentoo-77207d3d80b075208e9dd6b001d63d39a4ede9db.tar.bz2
gentoo-77207d3d80b075208e9dd6b001d63d39a4ede9db.zip
dev-python/ansi2html: add Python 3.9 support, misc. fixes
* Remove redundant src_compile. * Rely on distutils_enable_tests (chmod -x and setup.py check are not necessary). * Don't include manpage in DOCS. * Move test dependencies to BDEPEND. Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/ansi2html')
-rw-r--r--dev-python/ansi2html/ansi2html-1.5.2-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/ansi2html/ansi2html-1.5.2-r2.ebuild b/dev-python/ansi2html/ansi2html-1.5.2-r2.ebuild
new file mode 100644
index 000000000000..6bcbcf7230e1
--- /dev/null
+++ b/dev-python/ansi2html/ansi2html-1.5.2-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Convert text with ANSI color codes to HTML"
+HOMEPAGE="https://pypi.org/project/ansi2html/ https://github.com/ralphbean/ansi2html"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND=">=dev-python/six-1.7.3[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ doman man/${PN}.1
+ distutils-r1_python_install_all
+}