summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 12:42:47 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 12:51:06 +0100
commit81299d523ee6bb6e05b4ea4e4c68f919a24ef41f (patch)
tree5adffd77b308a22d2159909ccef4423395f853eb /dev-python/ansi
parentdev-python/yapf: Remove old (diff)
downloadgentoo-81299d523ee6bb6e05b4ea4e4c68f919a24ef41f.tar.gz
gentoo-81299d523ee6bb6e05b4ea4e4c68f919a24ef41f.tar.bz2
gentoo-81299d523ee6bb6e05b4ea4e4c68f919a24ef41f.zip
dev-python/ansi: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ansi')
-rw-r--r--dev-python/ansi/ansi-0.2.0-r1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/ansi/ansi-0.2.0-r1.ebuild b/dev-python/ansi/ansi-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..e29598da4af6
--- /dev/null
+++ b/dev-python/ansi/ansi-0.2.0-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="ANSI cursor movement and graphics in Python"
+HOMEPAGE="https://github.com/tehmaze/ansi"
+SRC_URI="https://github.com/tehmaze/${PN}/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest